HDU-2680 Choose the best route(最短路[Dijkstra])

21 篇文章 0 订阅


Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
  
  
1 -1

第一道用优先队列写的最短路题。

受到前几题的影响,没仔细读题,认为是无向边,WA后重看发现是有向边,改过后就AC


由于起点Kiki附近的公交车站有很多,而Kiki's friend附近的公交车站只有一个,所以将所有的有向边转向,即可将单目标最短路转换为单源最短路,然后裸敲Dijkstra模版即可




#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>

using namespace std;

struct Node {
    int e,w;
    bool operator < (const Node& a) const {
        return w>a.w;
    }
};

const int INF=0x3f3f3f3f;
int n,m,fin,s,e,k,ans;
bool vis[1005],fi[1005];
vector<vector<Node> > v;
priority_queue<Node> q;
Node p,pp;

void Dijkstra() {
    int i,j;
    ans=INF;
    while(!q.empty()) {
        p=q.top();
        q.pop();
        if(!vis[s=p.e]) {
            vis[s]=true;
            if(fi[s])//找到达到终点时最短的乘车时间
                ans=min(ans,p.w);
            for(i=0,j=v[s].size();i<j;++i) {
                pp.e=v[s][i].e;
                if(!vis[pp.e]) {
                    pp.w=p.w+v[s][i].w;
                    q.push(pp);
                }
            }
        }
    }
}

int main() {
    while(3==scanf("%d%d%d",&n,&m,&fin)) {
        v.clear();
        v.resize(n+1);
        memset(vis,false,sizeof(vis));
        memset(fi,false,sizeof(fi));
        while(m--) {
            scanf("%d%d%d",&s,&e,&k);
            p.e=s,p.w=k;//由于使用优先队列,所以不用判重边
            v[e].push_back(p);//WA一次后再仔细读题发现是有向边
        }
        scanf("%d",&k);
        while(k--) {
            scanf("%d",&e);
            fi[e]=true;//标记终点
        }
        p.e=fin,p.w=0;//起点入队
        q.push(p);
        Dijkstra();
        printf("%d\n",ans==INF?-1:ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值