USACO-Section 1.4 Arithmetic Progressions(枚举)

58 篇文章 0 订阅


Arithmetic Progressions

An arithmetic progression is a sequence of the form a, a+b, a+2b, ..., a+nb where n=0,1,2,3,... . For this problem, a is a non-negative integer and b is a positive integer.

Write a program that finds all arithmetic progressions of length n in the set S of bisquares. The set of bisquares is defined as the set of all integers of the form p2 + q2 (where p and q are non-negative integers).

TIME LIMIT: 5 secs

PROGRAM NAME: ariprog

INPUT FORMAT

Line 1:N (3 <= N <= 25), the length of progressions for which to search
Line 2:M (1 <= M <= 250), an upper bound to limit the search to the bisquares with 0 <= p,q <= M.

SAMPLE INPUT (file ariprog.in)

5
7

OUTPUT FORMAT

If no sequence is found, a single line reading `NONE'. Otherwise, output one or more lines, each with two integers: the first element in a found sequence and the difference between consecutive elements in the same sequence. The lines should be ordered with smallest-difference sequences first and smallest starting number within those sequences first.

There will be no more than 10,000 sequences.

SAMPLE OUTPUT (file ariprog.out)

1 4
37 4
2 8
29 8
1 12
5 12
13 12
17 12
5 20
2 24

数据很小,时间有5s,直接枚举即可。最后一组数据比官方标程慢了0.5s,本来有更好的优化,但是更浪费空间,就懒得改了。。。


/*
ID: your_id_here 
PROG: ariprog
LANG: C++
*/
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int n,m,maxb,nxt[62505],num,a,b,ans,temp,tmp,t,tt;
bool flag,legal[187505];//数组要开到62500*3,防止公差很大时越界

void sear() {
    temp=nxt[a],tmp=1;
    while(legal[tt=temp+b]&&tmp<n)
        temp=tt,++tmp;
    if((t=tmp-n)>=0) {
        flag=false;
        printf("%d %d\n",nxt[a],b);
    }
}

int main() {
    int i,j;
    freopen("ariprog.in","r",stdin);
    freopen("ariprog.out","w",stdout);
    while(2==scanf("%d%d",&n,&m)) {
        num=0;
        memset(legal,false,sizeof(legal));
        for(i=0;i<=m;++i)
            for(j=0;j<=m;++j)
                legal[i*i+j*j]=true;
        maxb=(t=(m*m)<<1)/(n-1);//最大的公差
        for(i=0;i<=t;++i)
            if(legal[i])
                nxt[num++]=i;
        flag=true;
        for(b=1;b<=maxb;++b)//枚举公差
            for(a=0;a<num;++a)//枚举等差数列第一项
                sear();
        if(flag)
            printf("NONE\n");
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值