【POJ-1003】Hangover

Hangover
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 87769 Accepted: 42382

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)

Source


由于此题的数据规模很小,可以先离线算出不超过5.20需要的卡片(tot)。
从题目可知 len[i]=len[i-1]+1/(i+1);因此len[tot]随着卡片tot的增长而增长,满足单调性,被查数在此区间段上。
考虑使用二分查找、
过程如下:
  初始时[left,right]=[1,tot]  ,中间指针为mid =(left+right)/2。
  若check(x-len[mid])>0 (即x>len[mid])则区间在右边,否则在左边。
  直到left+1>=right 。
#include <stdio.h>

double len[500];
int tot;

int check(double x)
{
	if (x>1e-8) return 1;
	return -1;
}
void pre()
{
	len[0]=0.0;
	for(tot=1;check(5.20-len[tot-1])>0;tot++)
		len[tot]=len[tot-1]+1.0/(tot+1);
}
int main()
{

	double x;
	int left,right,mid;
//	freopen("in.txt","r",stdin);
//	freopen("out.txt","w",stdout);
	pre();
	scanf("%lf",&x);
	while((x-0.0)>1e-8)
	{
		left=0;right=tot;
		while(left+1<right)
		{
			mid=(left+right)/2;
			if (check(x-len[mid])>0) left=mid;
				else right=mid;
		}
		printf("%d card(s)\n",right);
		scanf("%lf",&x);
	}

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值