POJ-1003 Hangover

Hangover

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 150249 Accepted: 72569

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We’re assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + … + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)

Source

http://poj.org/problem?id=1003

解释

这题就是个递推式子
就是说3张卡片 所能总的最大伸出量为1/2+1/3+1/4
现在给出 伸出量 问最少需要多少卡片
递推式为
res[0]=0.0;
res[i] =res[i-1]+1.0/(i+1); //i从1开始到276
因为276的时候就大于5.20了,后面的就不需要了
还有浮点数的比较 是两数相减小于x,x为精确度
1e-10,就是10的-10次方

代码

这里先进行了预处理,后面直接用

#include<iostream>
using namespace std;
int main()
{
	double a;
	double res[277]={0.00};
	for(int i=1;i<277;i++)
	{
		res[i] =res[i-1]+1.0/(i+1);
	}
	while(cin>>a)
	{
		if(a < 1e-10)// 判断a是否为0 
			break;
		for(int i=1;i<277;i++)
		{
			if(res[i]-a>1e-10)// 判断res[i]是大于0 
			{
				cout<< i<<" card(s)" <<endl;
				break;
			}
			   
		}
	}
	return 0;
}

人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

じ☆夏妮国婷☆じ

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值