【图论】 dijkstra算法

Description

Doge, tired of being a popular image on internet, is considering moving to another city for a new way of life. 
In his country there are N (2 ≤N≤ 1000) cities labeled 0 . . . N - 1. He is currently in city 0. Meanwhile, for each pair of cities, there exists a road connecting them, costing C  ij (a positive integer) for traveling from city i to city j. Please note that C  ij may not equal to C  ji for any given i ≠ j. 
Doge is carefully examining the cities: in fact he will divide cities (his current city 0 is  NOT included) into M (2 ≤ M ≤ 10  6) categories as follow: If the minimal cost from his current city (labeled 0) to the city i is Di, city i belongs to category numbered  Di mod M.Doge wants to know the “minimal” category (a category with minimal number) which contains at least one city. 
For example, for a country with 4 cities (labeled 0 . . . 3, note that city 0 is not considered), Doge wants to divide them into 3 categories. Suppose category 0 contains no city, category 1 contains city 2 and 3, while category 2 contains city 1, Doge consider category 1 as the minimal one. 
Could you please help Doge solve this problem? 

Note: 

ij is generated in the following way: 
Given integers X  0, X  1, Y  0, Y  1, (1 ≤ X  0, X  1, Y  0, Y  1≤ 1234567), for k ≥ 2 we have 
Xk  = (12345 + X  k-1 * 23456 + X  k-2 * 34567 + X  k-1 * X  k-2 * 45678)  mod  5837501 
Yk  = (56789 + Y  k-1 * 67890 + Y  k-2 * 78901 + Y  k-1 * Y  k-2 * 89012)  mod  9860381 
The for k ≥ 0 we have 

k = (X  k * 90123 + Y  k ) mod 8475871 + 1 

Finally for 0 ≤ i, j ≤ N - 1 we have 

ij = Z  i*n+j for i ≠ j 
ij = 0   for i = j 

Input

There are several test cases. Please process till EOF. 
For each test case, there is only one line containing 6 integers N,M,X  0,X  1,Y  0,Y  1.See the description for more details.

Output

For each test case, output a single line containing a single integer: the number of minimal category.

Sample Input

3 10 1 2 3 4
4 20 2 3 4 5

Sample Output

1
10

For the first test case, we have


	   0	   1	   2	   3	   4	   5	   6	   7	   8
X	   1	   2	 185180	 788997	1483212	4659423	4123738	2178800	 219267
Y	   3	   4	1633196	7845564	2071599	4562697	3523912	317737	1167849
Z	 90127	 180251	1620338	2064506	 625135	5664774	5647950	8282552	4912390

the cost matrix C is
	         	   0	 180251	1620338
	                2064506	   0	5664774
	                5647950	8282552	   0


        
  

Hint

   
   
So the minimal cost from city 0 to city 1 is 180251, while the distance to city 2 is 1620338. Given M = 10, city 1 and city 2 belong to category 1 and 8 respectively. Since only category 1 and 8 contain at least one city, the minimal one of them, category 1, is the desired answer to Doge’s question.

题意:有n个城市,城市之间相当于与路径(边),递推求出X[ ],Y[ ],Z[ ],从而求出C(i,j),也就是每条边上的权值,但是注意从i到j和从j到i的权值是不同的,只需按照题目给出的公式来求权值即可。所要求的就是从0点出发的最短路%m。   

   求最短路的思路就是dijkstra算法应用了。其实这题就是相当于没有直接给出每条边的权值,而是要自己来求出每条边的权值。下面给出代码~


【参考代码】

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
#define MAX 1010
#define INF 0X3f3f3f3f

int n, m;
long long X[MAX*MAX], Y[MAX*MAX], Z[MAX*MAX];
long long mp[MAX][MAX];

void dijkstra ()
{
    long long dist[MAX];
    bool vis[MAX];

    for (int i = 0; i < n; i++) dist[i] =(i==0?0: INF);
    memset (vis, 0, sizeof vis);

    for (int i = 0; i < n; i++)
    {
        long long min_f = INF, v;
        for (int j = 0; j < n; j++) if (!vis[j] && dist[j] < min_f)
            {
                min_f = dist[j];
                v = j;
            }
        vis[v] = 1;
        for (int j = 0; j < n; j++) if (!vis[j]&&dist[v]+mp[v][j]<dist[j])
            {
                dist[j]=dist[v]+mp[v][j];
            }
    }
    for (int i = 0; i < n; i++) dist[i] %= m;
    long long min_s=INF;

    for (int i = 1; i < n; i++)
    {
        min_s = min (min_s, dist[i]);
    }
    printf("%I64d\n",min_s);
}

int main ()
{

    while (scanf("%d%d%I64d%I64d%I64d%I64d",&n,&m,&X[0],&X[1],&Y[0],&Y[1])!=EOF)
    {
        for (int i = 2; i < n*n; i++)
        {
            X[i] = (12345 + X[i-1] * 23456 + X[i-2] * 34567 + X[i-1] * X[i-2] * 45678)  %  5837501;
            Y[i] = (56789 + Y[i-1] * 67890 + Y[i-2] * 78901 + Y[i-1] * Y[i-2] * 89012)  %  9860381;
        }

        for(int i=0; i<n*n; i++) Z[i] = (X[i]*90123 + Y[i]) % 8475871 + 1;

        for (int i = 0; i < n; i++)
        {
            for (int j = 0; j < n; j++)
            {
                if (i == j)
                    mp[i][j] = 0;
                else
                    mp[i][j] = Z[i*n+j];
            }
        }
        dijkstra ();
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值