zoj 2876 Phone List(tire 树)

Phone List

Time Limit: 5 Seconds      Memory Limit: 32768 KB

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

- Emergency 911
- Alice 97 625 999
- Bob 91 12 54 26
In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000.Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output "YES" if the list is consistent, or "NO" otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>
#define N 10
using namespace std;
struct trie
{
    struct trie *next[N];
    bool isword;
    int num;
}*head;
char temp[100];
int flag=0;
struct trie* hiti()
{
    struct trie* node = (struct trie *)malloc(sizeof(struct trie));
    node->num = 0;
    node->isword = false;
    memset(node->next , 0 , sizeof(node->next));
    return node;
}

void great_tree(char *a)
{
    struct trie *p = head,*q = NULL;
    int len = strlen(a);
    for(int i=0;i<len;i++)
    {
        int id = a[i]-'0';
        if(p->next[id]==NULL)
        {
            q = new (struct trie);
            for(int j=0;j<N;j++)
                q->next[j] = NULL;
            q->isword = 0;
            q->num = 0;
            p->next[id] = q;
        }
        if(p->next[id]->isword) flag = 1;
        if(i==len-1)
        {
            p->next[id]->isword = 1;
        }
        p = p->next[id];
    }
    for(int i=0;i<N;i++)
    if(p->next[i]!=NULL) flag = 1;
}
void del(struct trie *head)
{
    for(int i=0;i<N;i++)
    {
        if(head->next[i]!=NULL)
            del(head->next[i]);
    }
    delete head;
}
int find_tree(char a[])
{
    struct trie *p = head;
    int len = strlen(a);
    for(int i=0;i<len;i++)
    {
        int id = a[i]-'0';
     //   if(p->next[id]==NULL)
      //      return -1;
        p = p->next[id];
    }
    if(p->isword)
        return p->num;
}
int main()
{
    int Case,n;
    cin >> Case;
    getchar();
    while(Case--)
    {
        cin >> n ;
        getchar();
        flag = 0;
        head = hiti();
        for(int i=0;i<n;i++)
        {
            gets(temp);
            great_tree(temp);
        }
        if(!flag)
            cout << "YES" << endl;
        else
            cout << "NO"  << endl;
        del(head);
    }
    return 0;
}


1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看REaDME.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值