Problem Description
Now, here is a fuction:
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input
2 100 200
Sample Output
-74.4291 -178.8534
这个题要问的是最值问题,直接用的三分。
#if 0
#include<iostream>
#include<cmath>
#include<iomanip>
using namespace std;
double x,y;
double fun(double x)
{
double sum=(6.0*pow(x,7)+8.0*(pow(x,6))+7.0*pow(x,3)+5.0*pow(x,2)-y*x);
return sum;
}
int main()
{
int T;
cin>>T;
while(T--)
{
cin>>y;
double mid,midmid,l=0,r=100;
while(r-l>1.0e-6)
{
mid=(l+r)/2;
midmid=(mid+r)/2;
if(fun(mid)<fun(midmid)) //
{
r=midmid;
}
else
{
l=mid;
}
}
cout<<fixed<<setprecision(4)<<fun(l)<<endl;
}
}
#endif