PAT A1033. To Fill or Not to Fill (25)

13 篇文章 0 订阅

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (<= 100), the maximum capacity of the tank; D (<=30000), the distance between Hangzhou and the destination city; Davg (<=20), the average distance per unit gas that the car can run; and N (<= 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (<=D), the distance between this station and Hangzhou, for i=1,...N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print "The maximum travel distance = X" where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:
50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300
Sample Output 1:
749.17
Sample Input 2:
50 1300 12 2
7.10 0
7.00 600
Sample Output 2:
The maximum travel distance = 1200.00

#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <map>
#include <string>
#define Max 2000
using namespace std;
struct station
{
	int flag;
	double Price,Distance;
}S[Max];
bool cmp (station a,station b)
{
	return a.Distance<b.Distance;
}
int main()
{
	double n,k;
	int s;
	double m;
	scanf("%lf%lf%lf%d",&n,&m,&k,&s);
	for(int i=0;i<s;i++)
	{
		scanf("%lf %lf",&S[i].Price,&S[i].Distance);
		S[i].flag=0;
	}

	int z=s,x=0;
	double xd,d=0.00,p=0.00,y=0.00;
	sort(S,S+s,cmp);//路线图
	S[s].Distance=m;
	S[s].Price=0;
	S[s].flag=0;
	if(S[0].Distance!=0) printf("The maximum travel distance = 0.00\n");
    s=s+1;
	for(int i=0;i<s;i++)
	{
		int ff=-1,fff,v=-1,j;
		int max=100000000;
		
		for( j=i+1;j<s;j++)
		{
			if(S[j].Distance<=S[i].Distance+n*k)//可以达到
			{
				
				
				 if(S[j].Price<max)
				{
					v=j;
					max=S[j].Price;
					if(max<S[i].Price)
				{
					
					break;
				}
				}
			}
			else y=n;
		}
		if(v!=-1)//可以继续走下去
		{
			if(S[v].Price<S[i].Price)//存在比A点价格低的后置点
		       {
				   if(y<(S[v].Distance-S[i].Distance)/k)//油不够用的
				   {
			         p+=((S[v].Distance-S[i].Distance)/k-y)*S[i].Price;//先走到B点  正好没油
			         d=S[j].Distance;
			          y=0;
				   }
				   else //油够用
				   {
					   d=S[v].Distance;
					   y=y-(S[v].Distance-S[i].Distance)/k;
				   }
				   i=v-1;
		       }
			   else 
			   {
				   p+=(n-y)*S[i].Price;//加满油
				   y=n-(S[v].Distance-S[i].Distance)/k;//剩余油
				   d=S[v].Distance;
				   i=v-1;
			   }
		}
		else {
			d=d+y*k;
			break;
		}
	}
	if(d>=m) printf("%.2f\n",p);
	else printf("The maximum travel distance = %.2f",d);
    system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值