akoj-1229-An Easy Problem

An Easy Problem

Time Limit:1000MS  Memory Limit:65536K
Total Submit:15 Accepted:9

Description

n mathematics, a prime number (or a prime) is a natural number which has exactly two distinct natural number divisors: 1 and itself. In many cases, it is not enough to know whether a number is prime; sometimes, you need to know its factors.
Every positive integer greater than 1 can be expressed as a product of prime numbers. This factorization is unique and is called the prime factorization. For example, the number 60 can be decomposed into factors 2×2×3×5, each of which is prime. Note that the same prime can appear more than once in the factorization. Note that the same prime can appear more than once in the factorization.
Write a program to display the prime factorization of a number n.

Input

There are multiple test cases. Each case takes one line and contains exact one integer n(2≤n≤2^31-1).
n=0 indicates the end of the input and should not be processed by your program.

Output

For each case, output the prime factorization of a number n.

Sample Input

2
60
0

Sample Output

2
2*2*3*5

Source

[Submit]   [Go Back]   [Status]   [Discuss]

                 思路:分解因子

#include<iostream>
#include<string>
using namespace std;
const int D = 10000;
int primeF[D];
int main()
{
    int n;
    while(cin>>n)
    {
        if(n==0)
            break;
        int k = 0;
        for(int i=2; i<=n; ++i)
        {
            while(n%i==0)
            {
                primeF[k++] = i;
                n /= i;
            }
        }
        cout<<primeF[0];
        for(int i=1; i<k; ++i)
            cout<<"*"<<primeF[i];
        cout<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值