HDU 5400 Arithmetic Sequence

Problem Description
A sequence  b1,b2,,bn  are called  (d1,d2) -arithmetic sequence if and only if there exist  i(1in)  such that for every  j(1j<i),bj+1=bj+d1  and for every  j(ij<n),bj+1=bj+d2 .

Teacher Mai has a sequence  a1,a2,,an . He wants to know how many intervals  [l,r](1lrn)  there are that  al,al+1,,ar  are  (d1,d2) -arithmetic sequence.
 

Input
There are multiple test cases.

For each test case, the first line contains three numbers  n,d1,d2(1n105,|d1|,|d2|1000) , the next line contains  n  integers  a1,a2,,an(|ai|109) .
 

Output
For each test case, print the answer.
 

Sample Input
  
  
5 2 -2 0 2 0 -2 0 5 2 3 2 3 3 3 3
 

Sample Output
  
  
12 5
这题注意一下d1==d2的情况
#pragma comment(linker, "/STACK:1024000000,1024000000") 
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<cmath>
#include<cstdio>
#include<vector>
#include<string>
#include<cstring>
#include<algorithm>
#include<functional>
using namespace std;
typedef long long LL;
const LL base = 1e9 + 7;
const int maxn = 105;
LL T, n, m, f[maxn], a[maxn][maxn];

inline void read(int &x)
{
    char ch;
    while ((ch = getchar())<'0' || ch>'9');
    x = ch - '0';
    while ((ch = getchar()) >= '0' && ch <= '9') x = x * 10 + ch - '0';
}

int main()
{
    //read(T);
    for (int i = f[0] = 1; i <= 100; i++) f[i] = f[i - 1] * i % base;
    while (scanf("%I64d%I64d", &n, &m) != EOF)
    {
        LL tot = 0, ans = 1;
        for (int i = 1; i <= m; i++)
        {
            scanf("%I64d", &a[i][1]);
            if (a[i][1] == -1) tot++;
            else for (int j = 2; j <= n; j++)
            {
                scanf("%I64d", &a[i][j]);
                for (int k = j - 1; k; k--) if (a[i][j] == a[i][k]) ans = 0;
            }
        }
        for (int i = 1; i < tot; i++) ans = ans * f[n] % base;
        if (tot == 0)
        {
            for (int i = 1; i <= n; i++) a[0][i] = i;
            for (int i = m; i; i--)
                for (int j = 1; j <= n; j++) a[0][j] = a[i][a[0][j]];
            for (int i = 1; i <= n; i++) if (a[0][i] != i) ans = 0;
        }
        printf("%I64d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值