mac 下面 you have an outdated version of /usr/bin/install_name_tool installed

原创 2015年07月08日 08:45:53
我在macpro,系统版本10.10.1 ,安装composer的时候提示 you have an outdated version of /usr/bin/install_name_tool installed。
解决办法:先查看install_name_tool 的当前版本:otool -L /usr/bin/install_name_tool ,如图

发现版本过低,最简单的方法就是更新系统,更新到最新的10.10.4,再次查看版本
版本已经更新,再次运行之前命令即可

相关文章推荐

修改dylib的默认链接位置

有些dylib库并没有设置到/Framework里,当你将这些dylib添加到程序包中时,也无法正确调用。有一个解决方法: 用otool -L OOXX.dylib 查看链接位置 用 install_...
  • dadalan
  • dadalan
  • 2009年06月22日 10:17
  • 2558

Mac 改变动态库加载的路径

Mac下有专门的改变加载动态库路径的命令工具:install_name_tool 使用这个命令之前,首先查看目前加载动态库的路径,才能修改为新的路径,查看命令:otool  -L  应用程序。 ...

学会根据错误追查问题,解决问题

http://stackoverflow.com/questions/6383310/python-mysqldb-library-not-loaded-libmysqlclient-18-dylib...

ios应用加载第三方动态库dylib时崩溃及解决办法

最近在开发一个App需要以root权限运行,其中用到一个第三方合作开发的动态库。用theos创建工程,编译,打包,安装都没有问题,但是在手机上点击运行的时候崩溃,崩溃日志如下: {"bundleID"...

Java查看注册表错误:ERROR You have not installed the DLL named 'ICE_JNIRegistry.DLL'

用java进行注册表操作时出现以下错误: ERROR You have not installed the DLL named 'ICE_JNIRegistry.DLL'.     n...

Make sure you have the 32 bits Oracle Client installed.

上一次报这个错误的时候,我用的是32位数据库,算是误报,原因是日志超过2G了,。。。。 这一次是公司统一升级到11,32位连不上64位的了 下载instantclient-basic-...

PL/SQL连接报错问题 make sure you have the 32 bits oracle client installed

Windows 64位下装Oracle 11g 64位,PLSQL Developer使用出现以下问题: 1、Database下拉框为空:   2、强制输入用户名、密码及Databa...

解决:Cannot find System Java Compiler. Ensure that you have installed a JDK (not just a JRE)

导入github上的项目,有时候,就会报如下的错误 Error:Execution failed for task ':app:compileDebugJava'. > Cannot find S...

解决X64操作系统PL/SQL连接报错问题 make sure you have the 32 bits oracle client installed

Windows 64位下装Oracle 11g 64位,PLSQL Developer使用出现以下问题: 1、Database下拉框为空:   2、强制输入用户名、密码及Databa...
  • microfhu
  • microfhu
  • 2012年05月20日 18:06
  • 45885
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:mac 下面 you have an outdated version of /usr/bin/install_name_tool installed
举报原因:
原因补充:

(最多只允许输入30个字)