POJ 2253 Frogger 最短路径 Folyd

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14821 Accepted: 4902

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

         

 题意:一只青蛙在湖中一颗石头上, 它想去有另一只青蛙的石头上,但是 湖里的水很脏,它不愿意游泳,所以它要跳过去;

给出 两只青蛙所在石头的坐标, 及 湖里其他石头的坐标;任一两个坐标点间都是双向连通的。显然从A到B存在至少一条的通路,每一条通路的元素都是这条通路中前后两个点的距离,这些距离中又有一个最大距离。

现在要求求出所有通路的最大距离,并把这些最大距离作比较,把最小的一个最大距离作为青蛙的最小跳远距离。

思路:floyd变形 ,1Y 哦累累、、、

#include <iostream>
#include <cmath>
using namespace std;
double map[210][210];
int n;
struct Stone
{
	int x, y;
}s[210];
void Floyd()
{
	int i,j,k;
	for(k=0; k<n; k++)
	for(i=0; i<n-1; i++)
	for(j=i+1; j<n; j++)
	{
		if(map[i][j]>map[i][k] && map[i][j]>map[k][j])
		{
			if(map[i][k]>map[k][j])
				map[j][i]=map[i][j] = map[i][k];
			else 
				map[j][i]=map[i][j] = map[k][j];
		}
	}
}
double getdis(int a, int b)
{
	return sqrt((double)(s[a].x-s[b].x)*(s[a].x-s[b].x)+(double)(s[a].y-s[b].y)*(s[a].y-s[b].y));
}
int main()
{
	int Case=0,i,j;
	while(scanf("%d", &n), n)
	{
		for(i=0; i<n; i++)
			scanf("%d %d", &s[i].x, &s[i].y);
		for(i=0; i<n; i++)
		for(j=i+1; j<n; j++)
		{
			map[i][j]=map[j][i]=getdis(i,j);
		}
		Floyd();
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n", ++Case, map[0][1]);
	}
	return 0;
}


 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值