POJ 2996 Help Me with the Game 简单模拟

Help Me with the Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2081 Accepted: 1351

Description

Your task is to read a picture of a chessboard position and print it in the chess notation.

Input

The input consists of an ASCII-art picture of a chessboard with chess pieces on positions described by the input. The pieces of the white player are shown in upper-case letters, while the black player's pieces are lower-case letters. The letters are one of "K" (King), "Q" (Queen), "R" (Rook), "B" (Bishop), "N" (Knight), or "P" (Pawn). The chessboard outline is made of plus ("+"), minus ("-"), and pipe ("|") characters. The black fields are filled with colons (":"), white fields with dots (".").

Output

The output consists of two lines. The first line consists of the string "White: ", followed by the description of positions of the pieces of the white player. The second line consists of the string "Black: ", followed by the description of positions of the pieces of the black player.

The description of the position of the pieces is a comma-separated list of terms describing the pieces of the appropriate player. The description of a piece consists of a single upper-case letter that denotes the type of the piece (except for pawns, for that this identifier is omitted). This letter is immediatelly followed by the position of the piece in the standard chess notation -- a lower-case letter between "a" and "h" that determines the column ("a" is the leftmost column in the input) and a single digit between 1 and 8 that determines the row (8 is the first row in the input).

The pieces in the description must appear in the following order: King("K"), Queens ("Q"), Rooks ("R"), Bishops ("B"), Knights ("N"), and pawns. Note that the numbers of pieces may differ from the initial position because of capturing the pieces and the promotions of pawns. In case two pieces of the same type appear in the input, the piece with the smaller row number must be described before the other one if the pieces are white, and the one with the larger row number must be described first if the pieces are black. If two pieces of the same type appear in the same row, the one with the smaller column letter must appear first.

Sample Input

+---+---+---+---+---+---+---+---+
|.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|
+---+---+---+---+---+---+---+---+
|:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|
+---+---+---+---+---+---+---+---+
|...|:::|.n.|:::|...|:::|...|:p:|
+---+---+---+---+---+---+---+---+
|:::|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|...|:::|...|:::|.P.|:::|...|:::|
+---+---+---+---+---+---+---+---+
|:P:|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|.P.|:::|.P.|:P:|...|:P:|.P.|:P:|
+---+---+---+---+---+---+---+---+
|:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|
+---+---+---+---+---+---+---+---+

Sample Output

White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4

Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6

 

题意:给出 棋盘 情况 输出 白棋 和 黑棋在 棋盘上的坐标

            白棋为大写字母 黑棋为小写字母

棋盘 左下点为原点(1,a)

输出 是 按照KQRBNP的顺序

白棋 输出 行小的 行相同按列小的 先输出

黑棋 行大的先输出

思路: 模拟就行,没什么算法好说、、

s开小了 贡献一个WA、、、、

#include <iostream>
#include <algorithm>
using namespace std;
struct Pieces
{
	int x,y,p;
	char b;
}w[65],b[65];
int power(char p)
{
	if(p=='K' || p=='k') return 1;
	if(p=='Q' || p=='q') return 2;
	if(p=='R' || p=='r') return 3;
	if(p=='B' || p=='b') return 4;
	if(p=='N' || p=='n') return 5;
	if(p=='P' || p=='p') return 6;
}
bool cmp_w(Pieces a, Pieces b)
{
	if(a.p!=b.p) return a.p<b.p;
	if(a.x!=b.x) return a.x<b.x;
	return a.y<b.y;
}
bool cmp_b(Pieces a, Pieces b)
{
	if(a.p!=b.p) return a.p<b.p;
	if(a.x!=b.x) return a.x>b.x;
	return a.y<b.y;
}
int main()
{
	int i,j;
	int sum_b=0,sum_w=0;
	char a,d,c,s[100];
	for(i=8; i>=1; i--)
	{
		gets(s);
		for(j=0; j<8; j++)
		{
			getchar(); 
			scanf("%c%c%c", &a, &d, &c);
			if(d=='.' || d==':') continue;
			if(d>='a' && d<='z') 
			{
				b[sum_b].x = i;
				b[sum_b].y = j;
				b[sum_b].b = d-32;
				b[sum_b++].p = power(d);
			}
			else
			{
				w[sum_w].x = i;
				w[sum_w].y = j;
				w[sum_w].b = d;
				w[sum_w++].p = power(d);
			}
		}
		getchar();getchar();
	}
	sort(b, b+sum_b, cmp_b);
	sort(w, w+sum_w, cmp_w);
	gets(s);
	printf("White: ");
	for(i=0; i<sum_w; i++)
	{
		if(w[i].b!='P') printf("%c", w[i].b);
		printf("%c%d%c",w[i].y+'a', w[i].x, (i==sum_w-1)?'\n':',');
	}
	printf("Black: ");
	for(i=0; i<sum_b; i++)
	{
		if(b[i].b!='P') printf("%c",b[i].b);
		printf("%c%d%c",b[i].y+'a', b[i].x, (i==sum_b-1)?'\n':',');
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,这个问题属于技术问题。以下是一个简单的Python模拟登录POJ提交代码并抓取评测结果的代码示例: ```python import requests # 登录POJ,获取cookie def login(username, password): s = requests.Session() login_url = "http://poj.org/login" login_data = { "user_id1": username, "password1": password, "B1": "login", "url": "/" } s.post(login_url, data=login_data) return s # 提交代码 def submit_code(s, problem_id, language, source_code): submit_url = "http://poj.org/submit" submit_data = { "problem_id": problem_id, "language": language, "source": source_code } s.post(submit_url, data=submit_data) # 获取评测结果 def get_result(s, run_id): status_url = "http://poj.org/status" params = { "user_id": "", "result": "", "language": "", "top": run_id } r = s.get(status_url, params=params) table_start = r.text.find("<table cellpadding=0 cellspacing=0 border=0 width=100%>") table_end = r.text.find("</table>", table_start) table_html = r.text[table_start:table_end + 8] return table_html # 使用示例 username = "your_username" password = "your_password" problem_id = "1000" language = "G++" source_code = """ #include <iostream> using namespace std; int main() { int a, b; cin >> a >> b; cout << a + b << endl; return 0; } """ s = login(username, password) submit_code(s, problem_id, language, source_code) table_html = get_result(s, "12345678") # 替换成实际提交的run id print(table_html) ``` 其中,`login`函数模拟登录POJ并返回一个`Session`对象,`submit_code`函数提交代码,`get_result`函数获取评测结果。你可以根据实际需要修改代码中的`username`、`password`、`problem_id`、`language`和`source_code`等参数,并替换`get_result`函数中的`run_id`。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值