A Mathematical Curiosity

Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a2+b2+m)/(ab) is an integer.


Input

You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n ≤ 100.


Output

For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.


Sample Input

10 1
20 3
30 4
0 0

Sample Output

Case 1: 2
Case 2: 4
Case 3: 5


Source: East Central North America 1999 Practice


my c++ code:


#include <iostream>
using namespace std;
int main(){
    int n,m;
    int k = 0;
    cin>>n>>m;
    while(n){
        k++;
        int ans=0;
        float dou,cha;
        int num;
        for (double a = 1; a < n-1; a++){
            for (double b = a+1; b < n; b++){
                
                dou = (a*a + b*b + m)/(a*b);
                num = (a*a+b*b+m)/(a*b);
                cha = dou - num;
                if (cha==0.0){
                    ans++;
                }              
            }     
        }
        cout << "Case " << k <<": " << ans << endl; 
        cin>>n>>m;                   
    }    
   
    return 0;
}  
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值