zoj 3551 Bloodsucker 概率DP

In 0th day, there are n-1 people and 1 bloodsucker. Every day, two and only two of them meet. Nothing will happen if they are of the same species, that is, a people meets a people or a bloodsucker meets a bloodsucker. Otherwise, people may be transformed into bloodsucker with probability p. Sooner or later(D days), all people will be turned into bloodsucker. Calculate the mathematical expectation ofD.

Input

The number of test cases (T, T ≤ 100) is given in the first line of the input. Each case consists of an integern and a float numberp (1 ≤n < 100000, 0 <p ≤ 1, accurate to 3 digits after decimal point), separated by spaces.

Output

For each case, you should output the expectation(3 digits after the decimal point) in a single line.

Sample Input
1
2 1

Sample Output
1.000

 

 

 

/

 

 

#include<iostream>
#include<cstdio>


#include<cstring>


#include<algorithm>


using namespace std;
int n;
double p;
int main()
{
    int ci;scanf("%d",&ci);
    while(ci--)
    {
        scanf("%d%lf",&n,&p);
        if(n==1)
        {
            printf("0.000\n");continue;
        }
        double pre;
        double total=(double)n*(n-1)/2;
        pre=(1.0)/(1-2.0/n*(1-p)-1+2.0/n);
        for(int i=2;i<=n-1;i++)
        {
            double tmp=(double)i*(n-i);
            pre=(1+tmp/total*p*pre)/(1-tmp/total*(1-p)-1+tmp/total);
        }
        printf("%.3lf\n",pre);
    }
    return 0;
}


 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值