杭电1005.找规律就好

本题连接:点击打开链接

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 170439    Accepted Submission(s): 42050


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1071  1006  1007  1425  1205 
 

PS:本人ACM小白第一次玩CSDN,现在代码功底并不好,有错误请大家多多指教。

题意:已知:f1=f2=1,当n>=3时,f(n)=A*f(n-1)+B*f(n-2);现给出A,B,n的值,其中 (1 <= A, B <= 1000, 1 <= n <=100,000,000),求f(n)的值。

解题关键:找到规律,一看n的取值最大可到100,000,000,就应该要想到不能直接用数组来做,必须找到它的循环周期。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{

    int i,a,b,n;
    while(~scanf("%d%d%d",&a,&b,&n)&&(a+b+n))//当(a+b+n)均为0时退出
    {
        int s[101]= {0,1,1};                //每次都初始化数组
        for(i=3; i<100; i++)
        {
            s[i]=(a*s[i-1]+b*s[i-2])%7;         //计算数组s[3]之后的值
            if(s[i]==s[2]&&s[i-1]==s[1])        //本题关键,找到循环周期。
                break;                          //找到周期后直接退出循环
        }
        //printf("%d\n",i-2);
        n=n%(i-2);                          //周期为(i-2)
        if(n!=0)
            printf("%d\n",s[n]);
        else
            printf("%d\n",s[i-2]);
    }
    return 0;
}



}

评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值