PAT(甲级)1077

1077. Kuchiguse (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)
  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

    Now given a few lines spoken by the same character, can you find her Kuchiguse?

    Input Specification:

    Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

    Output Specification:

    For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".

    Sample Input 1:
    3
    Itai nyan~
    Ninjin wa iyadanyan~
    uhhh nyan~
    
    Sample Output 1:
    nyan~
    
    Sample Input 2:
    3
    Itai!
    Ninjinnwaiyada T_T
    T_T
    
    Sample Output 2:
    nai
    

#include <iostream>
#include <cstring>
#define SIZE 260
#define ROW 105

using namespace std;

char str[ROW][SIZE];

int main()
{
	int N;
//	freopen("test.txt","r",stdin);
	cin >>N;
	getchar();
	for(int i=0;i<N;i++){
		gets(str[i]);
	}
	int len1=strlen(str[0]);
	int len2=strlen(str[1]);
	int len = len1;
	char *p1=str[0];
	char *p2 = str[1];
	int count=0;
	bool flag = false;
	while(len1-1 >= 0 &&len2-1 >= 0 &&*(p1+len1-1) == *(p2+len2-1)){
		count++;
		len1--;
		flag = true;
		len2--;
	}
	if(!flag){
	    cout <<"nai\n";
		return 0;
	}
	for(int i=2;i<N;i++){
		p2 = str[i];
		len2= strlen(str[i]);
		len1 =len;
		int count1=0;
		bool flag = false;
		while(count1 < count &&len2-1 >= 0 &&*(p1+len1-1) == *(p2+len2-1)){
			flag =true;
			count1++;
			len1--;
			len2--;
		}
		if(!flag){
			cout <<"nai\n";
			return 0;
		}
		count = count > count1 ? count1:count;		
	}
	p1 = str[0]+len-count;
	cout <<p1 <<endl;
//	fclose(stdin);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值