PAT(甲级)1102

1102. Invert a Binary Tree (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

#include <iostream>
#include <deque>
#include <cstdio>
#include <stack>


using namespace std;

struct Node{
	Node():num(0),pre(-1),left(-1),right(-1){
	};
	int num,pre,left,right;
}nodes[10];

void Invert(int root){
	if(root ==-1 || nodes[root].left == -1 && nodes[root].right == -1)
	    return ;
	else{
		int tmp = nodes[root].left;
		nodes[root].left = nodes[root].right;
		nodes[root].right = tmp;
		Invert(nodes[root].left);
		Invert(tmp);
	}
}

deque<int>dq;
void Leveltravel(int root){
	printf("%d",root);
	if(nodes[root].left != -1)
	    dq.push_back(nodes[root].left);
	if(nodes[root].right != -1)
	    dq.push_back(nodes[root].right);
	while(!dq.empty()){
		int cur = dq.front();
		printf(" %d",cur);
		dq.pop_front();
		int left = nodes[cur].left;
		int right = nodes[cur].right;
		if(left != -1)
		    dq.push_back(left);
		if(right != -1)
		    dq.push_back(right);
	}
	printf("\n");
}
stack<int> ss;

void Inorder(int root){
	bool flag = false;
	int tmp = nodes[root].left;
	ss.push(root);
	while(!ss.empty() || tmp != -1){
		while(tmp != -1){
		    ss.push(tmp);
		    tmp = nodes[tmp].left;		
		}
		int cur = ss.top();
		ss.pop();
        if(!flag){
        	flag = true;
        	printf("%d",cur);
        }else
            printf(" %d",cur);
        tmp = nodes[cur].right;
	}
}

int find_root(int n){
	for(int i=0;i<n;i++)
	    if(nodes[i].pre == -1)
	        return i;
}

int main()
{
	int N;
	scanf("%d",&N);
	for(int i=0;i<N;i++){
		char ch1,ch2;
		cin >>ch1 >>ch2;
		nodes[i].num = i;
		if(ch1 != '-'){
			nodes[i].left = ch1 - '0';
			nodes[nodes[i].left].pre = i;
		}	    
		if(ch2 != '-'){
			nodes[i].right = ch2 -'0';
			nodes[nodes[i].right].pre = i;
		}
	}
	int root = find_root(N);
	Invert(root);
	Leveltravel(root);
	Inorder(root);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值