HDU 1361 Parencodings (模拟)

31 篇文章 0 订阅
16 篇文章 0 订阅

Parencodings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 913    Accepted Submission(s): 541

Problem Description
Let S = s1 s2 … s2n be a well-formed string of parentheses. S can be encoded in two different ways:

  • By an integer sequence P = p1 p2 … pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
  • By an integer sequence W = w1 w2 … wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).
Following is an example of the above encodings:
  S    (((()()())))
  P-sequence      4 5 6666
  W-sequence      1 1 1456
Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
Input
The first line of the input file contains a single integer t (1 t 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 n 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
Output
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Sample Input
  
  
2 6 4 5 6 6 6 6 9 4 6 6 6 6 8 9 9 9
Sample Output
  
  
1 1 1 4 5 6 1 1 2 4 5 1 1 3 9
Source
Recommend
JGShining   |   We have carefully selected several similar problems for you:  1379 1374 1370 1366 1332 

题意:
由括号序列S可经P规则和W规则变形为P序列和W序列。
p规则是:pi是第i个右括号左边的左括号的数;
w规则是:wi是第i右括号与它匹配的左括号之间右括号的数(其中包括它本身)。
输入p,输出w。
题解:
 设1是左括号,2是右括号。模拟一下咯。

AC代码:
#include<bits/stdc++.h>
using namespace std;
int n;
vector<int > V;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int k=1;
        for(int i=0;i<n;i++)
        {
            int x;
            scanf("%d",&x);
            for (int j=k;j<=x;j++)
            {
                V.push_back(1); //左括号 
            }
            V.push_back(2); //右括号 
            k=x+1;
        }
        
        vector<int > v;
        int d=V.size();
        for (int i=d-1;i>=0;i--)
        {
            if (V[i]==2) //右括号 
            {
                int ans=0;
                int cnt1=0,cnt2=0;
                for (int j=i;j>=0;j--)
                {
                    if (V[j]==2)//右括号 
                    {
                        cnt2++;
                        ans++;
                    }
                    else//左括号 
                    {
                        cnt1++;
                    }
                    if (cnt1==cnt2) break;
                }
                
                v.push_back(ans);
            }
        }
        for (int i=v.size()-1;i>=0;i--) 
		printf("%d%c",v[i],i==0?'\n':' ');
        V.clear();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值