hdu 1361 Parencodings

题目地址:

http://acm.hdu.edu.cn/showproblem.php?pid=1361

题目描述:

Parencodings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 675    Accepted Submission(s): 394


Problem Description
Let S = s1 s2 … s2n be a well-formed string of parentheses. S can be encoded in two different ways:

  • By an integer sequence P = p1 p2 … pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
  • By an integer sequence W = w1 w2 … wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:
  S    (((()()())))
  P-sequence      4 5 6666
  W-sequence      1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
 

Input
The first line of the input file contains a single integer t (1 t 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 n 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
 

Output
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
 

Sample Input
  
  
2 6 4 5 6 6 6 6 9 4 6 6 6 6 8 9 9 9
 

Sample Output
  
  
1 1 1 4 5 6 1 1 2 4 5 1 1 3 9




题意:


P-sequence 指的是左边有多少个左括号 W-sequence 指的是与匹配右括号之前的左括号的匹配过程中匹配的左括号有多少个(包括与最右边的括号匹配的左括号),问两者的转化过程。


题解:


将p序列转化成括号序列再讲括号序列转化成w序列。


转化规则:P序列每个元素值就有多少个左括号加1个右括号。多对一的关系。具体看代码。


代码:

#include <stdio.h>
#include <string.h>
char origin[30];
int p_seq[30], w_seq[30];
int t = 0, n = 0;
int main()
{
	while (scanf("%d", &t) != EOF&&t > 0)
	{
		while (t--)
		{
			scanf("%d", &n);
			int ori_len = 0;
			for (int i = 0; i <= n - 1; i++)		scanf("%d", &p_seq[i]);
			for (int i = 0; i <= n - 1; i++)
			{
				int left = i > 0 ? p_seq[i] - p_seq[i - 1] : p_seq[i];
				for (int j = 1; j <= left; j++)		origin[ori_len++] = '(';
				int right = 1;
				for (int j = 1; j <= right; j++)	origin[ori_len++] = ')';
				int match = 0,match_left = 0;//match the ')' and '('
				for (int j = ori_len - 1; j >= 0; j--)
				{
					if (origin[j] == ')') { match++;}
					else { match--; match_left++; }
					if (!match) break;
				}
				w_seq[i] = match_left;
			}
			printf("%d",w_seq[0]);
			for (int i = 1; i <= n - 1; i++)	 printf(" %d", w_seq[i]);
			printf("\n");
		}
	}
	return(0);
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值