HDU3833:YY's new problem

Problem Description
Given a permutation P of 1 to N, YY wants to know whether there exists such three elements P[i 1], P[i 2], P[i 3] that  
P[i 1]-P[i 2]=P[i 2]-P[i 3], 1<=i 1<i 2<i 3<=N.
 

Input
The first line is T(T<=60), representing the total test cases.
Each test case comes two lines, the former one is N, 3<=N<=10000, the latter is a permutation of 1 to N.
 

Output
For each test case, just output 'Y' if such i 1, i 2, i 3  can be found, else 'N'.
 

Sample Input
  
  
2 3 1 3 2 4 3 2 4 1
 

Sample Output
  
  
N Y


 

题意:就是找出数列中是否有满足P[i1]-P[i2]=P[i2]-P[i3], 1<=i1<i2<i3<=N.的存在

思路:今天看到学姐,也是我以前队友在群里问,于是无聊就去做下,其实还是很简单的,由于只有1~N,所以我们很容易联想到哈希,用哈希记录位置,原式可化为2*p2 = p1+p3,所以我们可以用过p1+p3来获得p2地址,看是否在p1,p3中间

光是这样还是会超时,那么我们再来个优化,可以发现p1+p3必然是偶数,这是最重要的优化之处

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int a[10005];
int hash[10005];

int main()
{
    int t,n,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i = 0; i<n; i++)
        {
            scanf("%d",&a[i]);
            hash[a[i]] = i;
        }
        int flag = 0;
        for(i = 0; i<n; i++)
        {
            for(j = i+1; j<n; j++)
            {
                int s = a[i]+a[j];
                if(s%2)//奇数肯定不符合
                continue;
                if(hash[s/2]>i && hash[s/2]<j)
                {
                    flag = 1;
                    break;
                }
            }
            if(flag)
                break;
        }
        printf("%s\n",flag?"Y":"N");
    }

    return 0;
}


 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值