HDU1495:非常可乐(BFS)

Problem Description
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。
 

Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
 

Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
 

Sample Input
  
  
7 4 3 4 1 3 0 0 0
 

Sample Output
  
  
NO 3
 


 

思路:将所有状态进行一次广搜即可,代码虽长,但基本都是复制粘贴

 

#include <string.h>
#include <stdio.h>
#include <queue>
using namespace std;

int s,n,m;
int vis[105][105][105];

struct node
{
    int s,n,m,step;
};
int check(int x,int y,int z)//平分条件
{
    if(x == 0 && y == z)
        return 1;
    if(y == 0 && x == z)
        return 1;
    if(z == 0 && x == y)
        return 1;
    return 0;
}

int bfs()
{
    queue<node> Q;
    node a,next;
    a.s = s;
    a.n = 0;
    a.m = 0;
    a.step = 0;
    vis[s][0][0] = 1;
    Q.push(a);
    while(!Q.empty())
    {
        a = Q.front();
        Q.pop();
        if(check(a.s,a.n,a.m))
            return a.step;
        if(a.n)//当n杯中还有
        {
            if(a.n>s-a.s)//将n杯倒入s杯中能将s杯倒满
            {
                next = a;
                next.n = next.n-(s-a.s);
                next.s = s;
                if(!vis[next.s][next.n][next.m])
                {
                    next.step = a.step+1;
                    Q.push(next);
                    vis[next.s][next.n][next.m] = 1;
                }
            }
            else//将n杯倒入s杯中不能将s杯倒满
            {
                next = a;
                next.s = next.n+next.s;
                next.n = 0;
                if(!vis[next.s][next.n][next.m])
                {
                    next.step = a.step+1;
                    Q.push(next);
                    vis[next.s][next.n][next.m] = 1;
                }
            }
            if(a.n>m-a.m)//将n杯倒入m杯中能将m杯倒满
            {
                next = a;
                next.n = next.n-(m-a.m);
                next.m =  m;
                if(!vis[next.s][next.n][next.m])
                {
                    next.step = a.step+1;
                    Q.push(next);
                    vis[next.s][next.n][next.m] = 1;
                }
            }
            else//将n杯倒入m杯中不能将m杯倒满
            {
                next = a;
                next.m = next.n+next.m;
                next.n = 0;
                if(!vis[next.s][next.n][next.m])
                {
                    next.step = a.step+1;
                    Q.push(next);
                    vis[next.s][next.n][next.m] = 1;
                }
            }
        }
        if(a.m)//同上
        {
            if(a.m>s-a.s)
            {
                next = a;
                next.m = next.m-(s-a.s);
                next.s = s;
                if(!vis[next.s][next.n][next.m])
                {
                    next.step = a.step+1;
                    Q.push(next);
                    vis[next.s][next.n][next.m] = 1;
                }
            }
            else
            {
                next = a;
                next.s = next.m+next.s;
                next.m = 0;
                if(!vis[next.s][next.n][next.m])
                {
                    next.step = a.step+1;
                    Q.push(next);
                    vis[next.s][next.n][next.m] = 1;
                }
            }
            if(a.m>n-a.n)
            {
                next = a;
                next.m = next.m-(n-a.n);
                next.n =  n;
                if(!vis[next.s][next.n][next.m])
                {
                    next.step = a.step+1;
                    Q.push(next);
                    vis[next.s][next.n][next.m] = 1;
                }
            }
            else
            {
                next = a;
                next.n = next.m+next.n;
                next.m = 0;
                if(!vis[next.s][next.n][next.m])
                {
                    next.step = a.step+1;
                    Q.push(next);
                    vis[next.s][next.n][next.m] = 1;
                }
            }
        }
        if(a.s)//同上
        {
            if(a.s>n-a.n)
            {
                next = a;
                next.s = next.s-(n-a.n);
                next.n = n;
                if(!vis[next.s][next.n][next.m])
                {
                    next.step = a.step+1;
                    Q.push(next);
                    vis[next.s][next.n][next.m] = 1;
                }
            }
            else
            {
                next = a;
                next.n = next.s+next.n;
                next.s = 0;
                if(!vis[next.s][next.n][next.m])
                {
                    next.step = a.step+1;
                    Q.push(next);
                    vis[next.s][next.n][next.m] = 1;
                }
            }
            if(a.s>m-a.m)
            {
                next = a;
                next.s = next.s-(m-a.m);
                next.m =  m;
                if(!vis[next.s][next.n][next.m])
                {
                   next.step = a.step+1;
                    Q.push(next);
                    vis[next.s][next.n][next.m] = 1;
                }
            }
            else
            {
                next = a;
                next.m = next.m+next.s;
                next.s = 0;
                if(!vis[next.s][next.n][next.m])
                {
                    next.step = a.step+1;
                    Q.push(next);
                    vis[next.s][next.n][next.m] = 1;
                }
            }
        }
    }
    return 0;
}

int main()
{
    int ans;
    while(~scanf("%d%d%d",&s,&n,&m),s||n||m)
    {
        if(s%2)//奇数肯定不能平分,因为被子是整数体积大小
        {
            printf("NO\n");
            continue;
        }
        memset(vis,0,sizeof(vis));
        ans = bfs();
        if(ans)
            printf("%d\n",ans);
        else
            printf("NO\n");
    }

    return 0;
}


 

  • 4
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值