UESTC - 1272:Final Pan's prime numbers【思维】

Time Limit: 1000MS Memory Limit: 65535KB 64bit IO Format: %lld & %llu

 Status

Description

Final Pan likes prime numbers very much.

One day, he want to find the super prime numbers.A prime numbers  ( >4) is a super prime number only if  -4 and  +4 are both prime numbers,too.

Your task is really easy:Give  ,find the maximum super prime number   that  <= .

Input

Only one integer 

Output

If there is no such interger  ,print' ',otherwise print  .

Sample Input

8

Sample Output

7

Hint

Source

第七届ACM趣味程序设计竞赛第四场(正式赛)

所有的超级奇数只有7。。。。。
AC-code:

#include<cstdio>
int main()
{
	long long i,n,ans;
	int flag1,flag2;
	scanf("%lld",&n);
	flag1=flag2=0;
	ans=0;
	if(n<7)
		printf("-1\n");
	else
		printf("7\n");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值