UESTC 1272-Final Pan's prime numbers

Final Pan's prime numbers

Edit

Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)

SubmitStatus

Final Pan likes prime numbers very much.

One day, he want to find the super prime numbers.A prime numbers n (n >4) is a super prime number only if n -4 and n +4 are both prime numbers,too.

Your task is really easy:Give N ,find the maximum super prime number n  that n <=N .

Input

Only one integer N.(4<N<10 12 ) 

Output

If there is no such interger n ,print'−1 ',otherwise print n .

Sample input and output

Sample InputSample Output
8
7

Hint

Source

第七届ACM趣味程序设计竞赛第四场(正式赛) 

题目大意:

题意就是找到1-n区间里面最大的素数,并且i+4和i-4都是素数。

解题思路:

很简单,你会发现只有7符合这个条件。

#include<stdio.h>
#include<string.h>
#include<algorithm>
int main()
{
	int nn;
	while(scanf("%d",&nn)!=EOF)
	{
		if(nn>6)
		printf("7\n");
		else
		printf("-1\n");
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值