nyoj 5 Binary String Matching

Binary String Matching

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit
输入
The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.
输出
For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.
样例输入
3
11
1001110110
101
110010010010001
1010
110100010101011 
样例输出
3
0

3

题目大意:求第二个字符串中包含有几个第一个字符串,
思路:一般的匹配算法,由于题中给出的时间限制比较充足,字符串的长度也不长
所以不用KMP算法,,这个比较简单,嘻嘻。
2015,3,14

#include<stdio.h>
#include<string.h>
int main(){
	int T,i,j,k,len1,len2,count;
	char s[15],t[1010],ch[15];
	scanf("%d",&T);
	while(T--){
		k=count=0;
		memset(ch,0,sizeof(ch));
		scanf("%s %s",s,t);
		len1=strlen(s);
		len2=strlen(t);
		j=0;
		for(i=0;i<len2;i++){
			ch[k++]=t[i];
			ch[k]='\0';
			if(k==len1){
				if(strcmp(ch,s)==0)
					count++;
				i=j;
				j++;
				k=0;
			}
		}
		printf("%d\n",count);	
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值