AYITACM2016省赛第二周 G - History Grading历史评分(最长公共子序列)

Description

Download as PDF

Background

Many problems in Computer Science involve maximizing some measure according to constraints.

Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events?

Some possibilities for partial credit include:

  1. 1 point for each event whose rank matches its correct rank
  2. 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.

For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).

In this problem you are asked to write a program to score such questions using the second method.

The Problem

Given the correct chronological order of n events tex2html_wrap_inline34 as tex2html_wrap_inline36 where tex2html_wrap_inline38 denotes the ranking of event i in the correct chronological order and a sequence of student responses tex2html_wrap_inline42 where tex2html_wrap_inline44 denotes the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.

The Input

The first line of the input will consist of one integer n indicating the number of events with tex2html_wrap_inline50 . The second line will contain nintegers, indicating the correct chronological order of n events. The remaining lines will each consist of n integers with each line representing a student's chronological ordering of the n events. All lines will contain n numbers in the range tex2html_wrap_inline60 , with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces.

The Output

For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking.

Sample Input 1

4
4 2 3 1
1 3 2 4
3 2 1 4
2 3 4 1

Sample Output 1

1
2
3

Sample Input 2

10
3 1 2 4 9 5 10 6 8 7
1 2 3 4 5 6 7 8 9 10
4 7 2 3 10 6 9 1 5 8
3 1 2 4 9 5 10 6 8 7
2 10 1 3 8 4 9 5 7 6

Sample Output 2

6
5
10
9

分析:

又是一题目比较容易理解,却不好提交对的题目,简单的最长公共子序列,

上一题是输入比较坑人。这次是没有好好去翻译英语,下意识就觉得是普通的序列,做错后才知道原来给的是时间发生的时间,而不是这个时间发生的时间,需要用数组重新对事件排序,才能正确去判定学生的序列是否正确!

#include<stdio.h>
#include<string.h>
int main()
{
    int n,i,j,t,a[25],b[25],s[25][25];
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d",&t);
        a[t]=i;  //第i个时间第t发生,所以t时间发生的i事件
    }
    while(scanf("%d",&t)!=EOF)
    {
        b[t]=0;
        memset(s,0,sizeof(s));
        for(i=1;i<n;i++)
          {
              scanf("%d",&t);
              b[t]=i;
          }
    for(i=1;i<=n;i++)  //普通的最长公共子序列
    for(j=1;j<=n;j++)
        if(a[i]==b[j])
        s[i+1][j+1]=s[i][j]+1;
    else
        s[i+1][j+1]=s[i][j+1]>s[i+1][j]?s[i][j+1]:s[i+1][j];
    printf("%d\n",s[n+1][n+1]);
    }
return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值