hdu 2680 Choose the best route 大年三十的首A 赤裸裸的Dijkstra 做这题需要一个小技巧

154 篇文章 1 订阅
50 篇文章 0 订阅

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8063    Accepted Submission(s): 2655


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
  
  
1 -1
 

--------------------------------------------------------------2015-02-18 16:03-----------------------------------------------------------

尽管条件很艰苦,尽管今天是大年三十,我还是在努力。

这题如果直接Dijkstra的话,多次求单源最短路径,会超时,但是我只要设置一个超级源点0,0到各个起点的距离为0,到其他各点距离为INF。就完美解决了!是不是很巧妙

另外该图是无向图。自己到自己也是INF

下面是代码:

#include <stdio.h>
#include <string.h>
#define MAX 1010
#define INF 100000000
int dis[MAX] , graph[MAX][MAX] ;
bool closed[MAX] ;
void dijkstra(int u , int n)
{
	for(int i = 1 ; i <= n ; ++i)
	{
		dis[i] = graph[u][i] ;
		closed[i] = false ;
	}
	closed[u] = true ;
	for(int i = 1 ; i <= n ; ++i)
	{
		int min = INF , index = 0 ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(!closed[j] && dis[j]<min)
			{
				min = dis[j];
				index = j ;
			}
		}
		if(min == INF)
		{
			break ;
		}
		closed[index] = true ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(graph[index][j] == INF)
			{
				continue ; 
			}
			if(dis[j]>dis[index] + graph[index][j])
			{
				dis[j] = dis[index] + graph[index][j] ;
			}
		}
	}
}

int main()
{
	int n , m ,s; 
	while(~scanf("%d%d%d",&n,&m,&s))
	{
		for(int i = 0 ; i <= n ; ++i)
		{
			for(int j = 0 ; j <= i ; ++j)
			{
				graph[i][j] = graph[j][i] = INF ;
			}
		}
		for(int i = 0 ; i < m ; ++i)
		{
			int x,y,w;
			scanf("%d%d%d",&x,&y,&w);
			if(graph[x][y] > w)
			{
				graph[x][y] = w ;
			}
		}
		
		int ans = INF , q ;
		scanf("%d",&q) ;
		for(int i = 0 ; i < q ; ++i)
		{
			int u ;
			scanf("%d",&u);
			graph[0][u] = 0;
		}
		dijkstra(0,n) ;
		ans = ans<dis[s]?ans:dis[s] ;
		if(ans == INF)
		{
			puts("-1") ;
		}
		else
		{
			printf("%d\n",ans) ;
		}
	}
	return 0 ;
}

与君共勉

有志者,事竟成。破釜沉舟,百二秦关终属楚。             

苦心人,天不负。卧薪尝胆,三千越甲可吞吴。


----------------------今2017/3/13,明天就要去南京大学复试了,距上次做这道题已经是两年前了,感慨万千--------------------------

顺便加个SPFA算法的代码

#include <cstdio>
#include <iostream>
#include <queue>
#include <cstring>

using namespace std ;

const int MAX = 40100 ;
const int INF = 1000000000;
struct Edge{
	int  to , w , next; 
}edges[MAX];

int head[MAX/20] , dis[MAX/20] ,cnt[MAX/20] ;
bool visited[MAX/20];
int n , m , s ;

void SPFA(int src)
{
	for(int i = 0 ; i <= n ; ++i)
	{
		dis[i] = INF ;
		visited[i] = false;
		cnt[i] = 0 ;
	}
	visited[src] = true ;
	dis[src] = 0 ; 
	queue<int> que ;
	que.push(src) ;
	while(!que.empty())
	{
		int v = que.front() ;
		que.pop() ;
		cnt[v] ++ ;
		visited[v] = false ;
		if(cnt[v]>n)
			return ;
		
		for(int i = head[v]; i != -1 ; i=edges[i].next)
		{
			if(dis[edges[i].to]>dis[v]+edges[i].w )
			{
				dis[edges[i].to] = dis[v]+edges[i].w ;
				if(!visited[edges[i].to])
				{
					que.push(edges[i].to) ;
					visited[edges[i].to] = true; 
				}
					
			}
			
		}
		
	}
}

int main()
{
	while(~scanf("%d%d%d",&n,&m,&s))
	{
		
		memset(head,-1,sizeof(head)) ;
		int i ;
		for(i = 0 ; i < m ; ++i)
		{
			int p , q , t ;
			scanf("%d%d%d",&p,&q,&t) ;
			edges[i].to = q ;
			edges[i].w = t ;
			edges[i].next = head[p] ;
			head[p] = i ; 
		}
		int w ;
		scanf("%d",&w) ;
		for(int j = 0 ; j < w ; ++j)
		{
			int t ;
			scanf("%d",&t) ;
			edges[i].to = t ;
			edges[i].w = 0 ;
			edges[i].next = head[0] ;
			head[0] = i ; 
			i++ ;
		}
		SPFA(0) ; 
		if(dis[s] == INF)
			puts("-1");
		else
			printf("%d\n",dis[s]) ;
		
	}
	
	return 0 ;
} 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值