POJ 1523 SPF 求割点及对应的连通分量数(入门题)


SPF
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5224 Accepted: 2418

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

Source


题意是说给你一个联通网路,求出这个网络所有割点的编号,以及如果删除这个割点之后所对应的联通分量数。
求割点的入门题。求割点用的是tarjan算法,以下链接是神一般的解释。

<pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
#include<algorithm>
#define M 1007
using namespace std;
int low[M],dfn[M],head[M],vis[M],cut[M];//cut记录割点
int n,cnt,num,t,root,root_son,textcase;
struct E
{
    int to,next;
}edg[M*20];

void init()
{
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
    memset(head,-1,sizeof(head));
    memset(vis,0,sizeof(vis));
    memset(cut,0,sizeof(cut));
    cnt=0;
    textcase++;
    num=1;
    n=-1;
}

void addedge(int u,int v)
{
    edg[cnt].to=v;
    edg[cnt].next=head[u];
    head[u]=cnt++;
}

void Tarjan(int u)
{
    low[u]=dfn[u]=num++;
    for(int i=head[u];i!=-1;i=edg[i].next)
    {
        int v=edg[i].to;
        if(!dfn[v])
        {
            Tarjan(v);
            if(u==root)//若k为深搜树的根Root,当且仅当k的儿子数(分支数)>=2时k为割点;
                root_son++;
            else//若k为搜索树的中间结点(即k既不为根也不为叶),那么k必然有father和son,若low[son]>= dfn[k],则k必然为割点。
            {
                if(low[u]>low[v])
                    low[u]=low[v];
                if(low[v]>=dfn[u])
                    cut[u]=1;
            }

        }
        else if(low[u]>dfn[v])
            low[u]=dfn[v];
    }
}

void dfs(int u)//找联通分量
{
    vis[u]=1;
    for(int k=head[u];k!=-1;k=edg[k].next)
    {
        int v=edg[k].to;
        if(!vis[v])
        {
            vis[v]=1;
            dfs(v);
        }

    }
}

int main()
{
    int u,v;
    textcase=0;
    while(scanf("%d",&u),u)
    {
        init();
        n=max(n,u);
        scanf("%d",&v);
        n=max(n,v);
        addedge(u,v);
        addedge(v,u);
        while(scanf("%d",&u),u)
        {
            n=max(n,u);
            scanf("%d",&v);
            n=max(n,v);
            addedge(u,v);
            addedge(v,u);
        }
        root=1;
        root_son=0;
        int flag=0;
        Tarjan(root);
        if(root_son>1)
            cut[root]=1;
        printf("Network #%d\n",textcase);
        for(int i=1;i<=n;i++)
        {
            if(cut[i])
            {
                flag=1;
                memset(vis,0,sizeof(vis));
                vis[i]=1;
                int son=0;
                for(int j=head[i];j!=-1;j=edg[j].next)
                {
                    int v=edg[j].to;
                    if(!vis[v])
                    {
                        dfs(v);
                        son++;
                    }
                }
                printf("  SPF node %d leaves %d subnets\n",i,son);
            }
        }
        if(!flag)
            printf("  No SPF nodes\n");
        printf("\n");
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值