poj 1068 (Parencodings)

27 篇文章 0 订阅
7 篇文章 0 订阅

Time Limit: 1000MS Memory Limit: 10000KB 64bit IO Format: %lld & %llu

 Status

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

题意:P串是从第一个右括号开始,看该右括号前面有多少左括号的字符串,W串是与该右括号匹配的左括号中间隔多少个左括号的字符串

分析:根据P串模拟出来括号的存储情况,用正负数字,表示左括号和右括号,最后找相应的括号。

代码如下:

#include <stdio.h>
#include <string.h>
int main()
{
	int T,n;
	int i,j,k,d;
	int a[45],b[45],c[45];
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		int index = 0;
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		memset(c,0,sizeof(c));
		int left,right;
		left = 0;
		right= 0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&d);
			for(j=left;j<d;j++)
				a[index++]=-j;	//左括号的赋值,每次数字增大,才增加左括号 
			if(d>left)
				a[index++]=d-1;	//每次输入一个数字都是一个右括号
								//但要判断该右括号与那个匹配 
			else
			{
				int max=-1;
				for(j=0;j<left;j++)
				{
					if(b[j]==0 && j>max)
						max=j;
				}
				a[index++]=max;
			}
			left = d;
			b[a[index-1]]=1;
		}
		
		/*for(i=0;i<index;i++)
			printf("%d ",a[i]);
		putchar('\n');*/		//输出括号情况 
		j=0;
		for(i=0;i<n;i++)
		{
			j++;
			for(;j<index;j++)
				if(a[j]>=0 && j!=0)
					break;
			int cnt=0;
			for(k=j-1;k>=0;k--){
				if(a[j]==-a[k])
					break;
				else if(a[k]<0)
					cnt++;
			}
			c[i]=cnt+1;
		}
		if(n>0)
			printf("%d",c[0]);
		for(i=1;i<n;i++)
			printf(" %d",c[i]);
		putchar('\n');
	}
	
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值