poj 1013 Counterfeit Dollar(模拟题)

40 篇文章 0 订阅
27 篇文章 0 订阅

Counterfeit Dollar
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 45332 Accepted: 14324

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light. 

题意:

有12个钱币,其中有一个是假的,假钱轻重不确定,根据3次比较,找出那个假钱,并指出是轻还是重。

分析:

模拟一下,如果天平平衡,说明两边都是真钱,标记一下,如果一重一轻,轻的一边所有钱的标记-1,重的一边+1,最后看最有可能是假钱的是哪一个(该钱标记的绝对值最大)。

坑点:没有读好题,天平两边放任意个钱(不止是示例中所给的四个),所以输入和循环的时候要根据长度来。

#include <stdio.h>
#include <math.h>
#include <string.h>
#define INF 10
int ans[15];
int main()
{
	int T;
	int i,j,k; 
	char str[3][20];
	scanf("%d",&T);
	while(T--)
	{
		memset(ans,0,sizeof(ans));
		for(i=0;i<3;i++)
		{
			for(j=0;j<3;j++)
				scanf("%s",str[j]);
			int len = strlen(str[0]);
			if(strcmp(str[2],"even")==0)
			{
				for(j=0;j<2;j++)
				{
					for(k=0;k<len;k++)
						ans[str[j][k]-'A']=INF;	//INF标记为是真的 
				}
			}
			else if(strcmp(str[2],"up")==0)
			{
				for(k=0;k<len;k++)
				{
					if(ans[str[0][k]-'A']!=INF)
						ans[str[0][k]-'A']++;
				}
				for(k=0;k<len;k++)
				{
					if(ans[str[1][k]-'A']!=INF)
						ans[str[1][k]-'A']--;
				}
			}
			else
			{
				for(k=0;k<len;k++)
				{
					if(ans[str[1][k]-'A']!=INF)
						ans[str[1][k]-'A']++;
				}
				for(k=0;k<len;k++)
				{
					if(ans[str[0][k]-'A']!=INF)
						ans[str[0][k]-'A']--;
				}
			}
		}
		int max=-INF,index;
		for(i=0;i<12;i++)
		{
			if(ans[i]!=INF && fabs(ans[i]-0)>max)
			{
				max=fabs(ans[i]-0);
				index=i;
			}
		}
		
		if(ans[index]<0)
			printf("%c is the counterfeit coin and it is light.\n",index+'A');
		else
			printf("%c is the counterfeit coin and it is heavy.\n",index+'A');	
	}
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值