HDU - 2689 Sort it

Sort it

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4980    Accepted Submission(s): 3431


Problem Description
You want to processe a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. Then how many times it need.
For example, 1 2 3 5 4, we only need one operation : swap 5 and 4.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 1000); the next line contains a permutation of the n integers from 1 to n.
 

Output
For each case, output the minimum times need to sort it in ascending order on a single line.
 

Sample Input
  
  
3 1 2 3 4 4 3 2 1
 

Sample Output
  
  
0


冒泡排序要交换几次 模拟冒泡排一下记录即可 或者用树状数组求逆序数


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#define max_ 1010
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
int n;
int num[max_];
int main(int argc, char const *argv[])
{
	while(scanf("%d",&n)!=EOF)
	{
		int i;
		for(i=1;i<=n;i++)
			scanf("%d",&num[i]);
		int cnt=0;
		for(i=1;i<n;i++)
		{
			for(int j=1;j<n;j++)
			{
				if(num[j]>num[j+1])
				{
					swap(num[j],num[j+1]);
					cnt++;
				}
			}
		}
		printf("%d\n",cnt);
	}
	return 0;
}

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<set>
#include<map>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 100005
#define maxn 10005
#define ll long long
int c[maxn],n;
int lowbit(int a)
{
    return a&(-a);
}
void update(int i,int x)
{
    while(i<=n)
    {
        c[i]+=x;
        i+=lowbit(i);
    }
}
int getsum(int i)
{
    int sum=0;
    while(i>0)
    {
        sum+=c[i];
        i-=lowbit(i);
    }
    return sum;
}
int main()
{
    int a[maxn];
    while(cin>>n)
    {
        memset(c,0,sizeof(c));
        int sum=0;
        for(int i=0;i<n;i++)
            {
                cin>>a[i];
                update(a[i],1);
                sum+=i-getsum(a[i]-1);
            }
            cout<<sum<<endl;
}
return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值