HDU-5534-Partial Tree【2015长春赛区】【完全背包】


HDU-5534-Partial Tree【2015长春赛区】【完全背包】


        Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)

Problem Description
In mathematics, and more specifically in graph theory, a tree is an undirected graph in which any two nodes are connected by exactly one path. In other words, any connected graph without simple cycles is a tree.

You find a partial tree on the way home. This tree has n nodes but lacks of n−1 edges. You want to complete this tree by adding n−1 edges. There must be exactly one path between any two nodes after adding. As you know, there are nn−2 ways to complete this tree, and you want to make the completed tree as cool as possible. The coolness of a tree is the sum of coolness of its nodes. The coolness of a node is f(d), where f is a predefined function and d is the degree of this node. What’s the maximum coolness of the completed tree?

Input
The first line contains an integer T indicating the total number of test cases.
Each test case starts with an integer n in one line,
then one line with n−1 integers f(1),f(2),…,f(n−1).

1≤T≤2015
2≤n≤2015
0≤f(i)≤10000
There are at most 10 test cases with n>100.

Output
For each test case, please output the maximum coolness of the completed tree in one line.

Sample Input
2
3
2 1
4
5 1 4

Sample Output
5
19

题目链接:HDU-5534

题目大意:让你构造一个有n(2≤n≤2015)个节点的树。然后定义这棵树的coolness为∑f(d),其中d是每个节点的度数,函数f在输入中给出。

题目思路:一颗含有n个节点的树,有n−1条边,度数之和为2n−2。所以我们可以转化成一个完全背包问题:

一开始假设大家的度数都为1,然后慢慢地增大,让大家的度数和增大到2n−2。
dp[i]表示i个度的最优值
那么有状态转移方程:dp[i + j - 1] = max(dp[i + j - 1],dp[j] + num[i] - num[1]);
最终所求的答案就是dp[n-2]

以下是代码:

#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;
int num[2050];
int dp[2050];
int n;
#define INF 0x3f3f3f3f
void solve()
{
    for (int i = 0; i <= n; i++) dp[i] = -INF;  //初始化
    dp[0] = 0;
    for (int i = 2; i < n; i++) 
    {
        for (int j = 0; i + j - 1 <= n - 2; j++)
        {
            dp[i + j - 1] = max(dp[i + j - 1],dp[j] + num[i] - num[1]);
        }
    }
}
int main(){
    int t;
    cin >> t;
    while(t--)
    {
        scanf("%d",&n);
        memset(dp,0,sizeof(dp));
        memset(num,0,sizeof(num));
        for (int i = 1; i <= n - 1; i++)
        {
            scanf("%d",&num[i]);
        }
        solve();
        int ans = dp[n - 2] + num[1] * n;
        printf("%d\n",ans);
    } 
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值