ZOJ-3607-Lazier Salesgirl【模拟】【贪心】【9th浙江省赛】

56 篇文章 0 订阅
23 篇文章 0 订阅

ZOJ-3607-Lazier Salesgirl


                        Time Limit: 2 Seconds      Memory Limit: 65536 KB

Kochiya Sanae is a lazy girl who makes and sells bread. She is an expert at bread making and selling. She can sell the i-th customer a piece of bread for price pi. But she is so lazy that she will fall asleep if no customer comes to buy bread for more than w minutes. When she is sleeping, the customer coming to buy bread will leave immediately. It’s known that she starts to sell bread now and the i-th customer come after ti minutes. What is the minimum possible value of w that maximizes the average value of the bread sold?

Input
There are multiple test cases. The first line of input is an integer T ≈ 200 indicating the number of test cases.

The first line of each test case contains an integer 1 ≤ n ≤ 1000 indicating the number of customers. The second line contains n integers 1 ≤ pi ≤ 10000. The third line contains n integers 1 ≤ ti ≤ 100000. The customers are given in the non-decreasing order of ti.

Output
For each test cases, output w and the corresponding average value of sold bread, with six decimal digits.

Sample Input
2
4
1 2 3 4
1 3 6 10
4
4 3 2 1
1 3 6 10

Sample Output
4.000000 2.500000
1.000000 4.000000

题目链接:ZOJ-3607

题目大意:一个女孩做面包,给出第i个顾客的还有ti分钟到达,购买面包的价格为pi。如果w分钟都没有顾客到,小女孩会睡着,就不做面包了。求平均价值最大的情况下,最小的w。

题目思路:贪心模拟就可以了,求出每个时间的w和ave,找出最大的ave的情况下最小的w。

以下是代码:

#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;
#define INF 0x3f3f3f
#define EPS 1e-6
#define MAXN 1005
double p[MAXN],t[MAXN];
double ave[MAXN],w[MAXN];
int main(){
    int T;
    cin >> T;
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for (int i = 0; i < n; i++)
        {
            cin >> p[i];
        }
        for (int i = 0; i < n; i++)
        {
            cin >> t[i];
            if (i == 0) w[i] = t[i];
            else w[i] = max(t[i] - t[i - 1],w[i - 1]);
        }
        double max_ave = 0,min_w = 0;
        for (int i = 0; i < n; i++)
        {
            int time = w[i];
            double sum = 0;
            int j = 0;
            for (j = 0; j < n; j++)
            {
                if (w[j] > time) break;
                sum += p[j];
            }
            if (sum / j > max_ave) max_ave = sum / j,min_w = time;
            else if (sum / j == max_ave && min_w > time) min_w = time;
        }
        printf("%.6f %.6f\n",min_w,max_ave);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值