ZOJ 3607Lazier Salesgirl (模拟题)


Description

Kochiya Sanae is a lazy girl who makes and sells bread. She is an expert at bread making and selling. She can sell the i-th customer a piece of bread for price pi. But she is so lazy that she will fall asleep if no customer comes to buy bread for more than w minutes. When she is sleeping, the customer coming to buy bread will leave immediately. It's known that she starts to sell bread now and the i-th customer come after ti minutes. What is the minimum possible value of w that maximizes the average value of the bread sold?

Input

There are multiple test cases. The first line of input is an integer T ≈ 200 indicating the number of test cases.

The first line of each test case contains an integer 1 ≤ n ≤ 1000 indicating the number of customers. The second line contains n integers 1 ≤ pi ≤ 10000. The third line contains n integers 1 ≤ ti ≤ 100000. The customers are given in the non-decreasing order of ti.

Output

For each test cases, output w and the corresponding average value of sold bread, with six decimal digits.

Sample Input

2
4
1 2 3 4
1 3 6 10
4
4 3 2 1
1 3 6 10

Sample Output

4.000000 2.500000
1.000000 4.000000


思路:模拟一下,注意之后的间隔的时间如果小于自己挑选的,那么也要加进去...


省赛总结,给自己弄几组测试数据,要仔细+细心....


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[1111],b[1111],c[1111];
double sum[1111];
int main()
{
	int T,i,j,tem,n;
	double aver,w;
	scanf("%d",&T);
	while(T--) {
		scanf("%d",&n);
		for(i=1;i<=n;i++) {
			scanf("%d",&a[i]);
			sum[i]=0;
		}
		for(i=1;i<=n;i++) {
			scanf("%d",&c[i]);
			sum[i]+=sum[i-1]+a[i];
		}
		for(i=1;i<=n;i++) b[i]=c[i]-c[i-1];
		w=b[1];
		for(i=2;i<=n;i++) {
			if(b[i]>w) break;
		}
		aver=1.0*sum[i-1]/(i-1);
		for(;i<=n;) {
			tem=b[i];
			for(;i<=n;i++) {
				if(b[i]>tem) break;
			}
			if(1.0*sum[i-1]/(i-1)>aver) {
				w=tem;
				aver=1.0*sum[i-1]/(i-1);
			}
		}
		printf("%.6lf %.6lf\n",w,aver);
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值