数据结构实验之链表四:有序链表的归并

数据结构实验之链表四:有序链表的归并

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

分别输入两个有序的整数序列(分别包含M和N个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

输入

第一行输入M与N的值; 
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。

输出

输出合并后的单链表所包含的M+N个有序的整数。

示例输入

6 5
1 23 26 45 66 99
14 21 28 50 100

示例输出

1 14 21 23 26 28 45 50 66 99 100

提示

不得使用数组!
#include<stdio.h>
#include<stdlib.h>

typedef struct node
{
    int data;
    struct node *next;
}Node;

Node *creatList(int n)
{
    Node *head,*tail,*p;
    int i;
    head=(Node *)malloc(sizeof(Node ));
    head->next=NULL;
    tail=head;
    for(i=0;i<n;i++)
    {
        p=(Node *)malloc(sizeof(Node ));
        scanf("%d",&p->data);
        p->next=tail->next;
        tail->next=p;
        tail=p;
    }
    return head;
}

Node *Merge(Node *head1,Node *head2)
{
    Node *p1,*p2,*tail;
    p1=head1->next;
    p2=head2->next;
    tail=head1;
    free(head2);
    while(p1&&p2)
    {
        if(p1->data<p2->data)
        {
            tail->next=p1;
            tail=p1;
            p1=p1->next;
        }
        else
        {
            tail->next=p2;
            tail=p2;
            p2=p2->next;
        }
        if(p1)
            tail->next=p1;
        else
            tail->next=p2;
    }
        return head1;
}

void show(Node *head)
{
    Node *r;
    r=head->next;
    while(r)
    {
        if(r->next==NULL)
            printf("%d\n",r->data);
        else
            printf("%d ",r->data);
        r=r->next;
    }
}
void main()
{
    int n,m;
    Node *head,*head1,*head2;
    scanf("%d %d",&n,&m);
    head1=creatList(n);
    head2=creatList(m);
    head=Merge(head1,head2);
    show(head);
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值