poj 2139 Floyd最短路径

http://vjudge.net/contest/view.action?cid=48211#problem/A

Description

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon". 

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case. 

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows. 

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were. 

Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows. 

Sample Input

4 2
3 1 2 3
2 3 4

Sample Output

100

Hint

[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .] 
题目大意:有n头牛,如果两头牛同拍一部电影,这他们之间的距离为一,如果两头牛都和第三头牛拍过同一部电影,那么它们之间的距离经第三头牛传递就为2,,,求那一头牛与其它牛距离的平均值最小,把他乘一百输出。(求的时候,先扩大一百倍再求平均值)

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
const int oo=1e9+1;
int a[305][305];
void prepare()
{
    for(int i=0;i<305;i++)
        for(int j=0;j<305;j++)
            if(i!=j)
                a[i][j]=a[j][i]=oo;
}
int b[106];
int main()
{
    int n,m,x;
    while(~scanf("%d%d",&n,&m))
    {
        prepare();
        while(m--)
        {
            scanf("%d",&x);
            for(int i=0;i<x;i++)
                scanf("%d",&b[i]);
            for(int i=0;i<x;i++)
                for(int j=i+1;j<x;j++)
                    a[b[i]][b[j]]=a[b[j]][b[i]]=1;
        }
        for(int k=1;k<=n;k++)
            for(int i=1;i<=n;i++)
               for(int j=1;j<=n;j++)
                     a[i][j]=min(a[i][j],a[i][k]+a[k][j]);
        int minn=oo;
        for(int i=1;i<=n;i++)
        {
            int maxn=0;
            for(int j=1;j<=n;j++)
                   maxn+=a[i][j];
            minn=min(minn,100*maxn/(n-1));
        }
        printf("%d\n",minn);
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值