poj 2139 Six Degrees of Cowvin Bacon 最短路

Six Degrees of Cowvin Bacon
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2213 Accepted: 1034

Description

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon". 

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case. 

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows. 

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were. 

Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows. 

Sample Input

4 2
3 1 2 3
2 3 4

Sample Output

100

Hint

[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .] 

Source




#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int INF=10000000;

int map[333][333];
int dis[333];
int vis[333];
int n,m;

void dijkstra(int s)
{
    int i,j,k,mn;
    for(i=1;i<=n;i++)
        dis[i]=map[s][i],vis[i]=0;
    vis[s]=1;
    for(i=1;i<=n;i++)
    {
        k=s;
        mn=INF;
        for(j=1;j<=n;j++)
            if(!vis[j]&&dis[j]<mn)
                k=j,mn=dis[j];
        vis[k]=1;
        for(j=1;j<=n;j++)
            if(!vis[j]&&(map[k][j]+dis[k])<dis[j])
                dis[j]=dis[k]+map[k][j];
    }

}

int main()
{
    int i,j,k,p;
    int a[333];
    cin>>n>>m;
    for(i=1;i<=n;i++)
         for(j=1;j<=n;j++)
            if(i==j)
                map[i][j]=0;
            else
                map[i][j]=INF;
    for(i=0;i<m;i++)
    {
        memset(a,0,sizeof(a));
        scanf("%d",&k);
        for(j=0;j<k;j++)
        {
            scanf("%d",&a[j]);
            //cout<<a[j]<<endl;
        }
        for(j=0;j<k;j++)
        {
            for(p=j+1;p<k;p++)
                {
                    map[a[j]][a[p]]=map[a[p]][a[j]]=1;
                }
        }
    }
    double Min=INF,sum;
    for(i=1;i<=n;i++)
    {
        sum=0;
        dijkstra(i);
        for(j=1;j<=n;j++)
          sum+=dis[j];
        //cout<<sum<<endl;
        Min=min(Min,sum);
    }
    Min=(Min/(n-1))*100;
    int ans=(int)Min;
    cout<<ans<<endl;
    return 0;
}

发现自己偏爱dijkstra。。
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值