poj3255-Roadblocks-次短路

     Roadblocks

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersectionN.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R
Lines 2..R+1: Each line contains three space-separated integers: A,B, and D that describe a road that connects intersections A andB and has length D (1 ≤ D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and nodeN

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

题目大意

有n个路口r条马路,马路可以重复走,问从1号路口到n号路口的次短路


解题思路

次短路问题,实际上可以这么理解:

在知道最短路的情况下,不走最短路,绕一段路,而且只能绕一段路,否则会不满足次短。

所以就先找到最短路并记录下路径,然后枚举最短路上的每一个点a,从这个点再绕一个点b,然后再加上点b到n的最短路。

所以我们需要知道从1到每个点的最短路,还需要知道从每个点到n的最短路,从每个点到n的最短路就是从n到每个点的最短路

所以两次dijkstra 然后枚举次短路就好啦

代码

#include <cstring>
#include <cstdio>
#include <iostream>
#include <vector>
#define INF 0x3f3f3f3f
const int maxn=5010;
using namespace std;
int n,r;//n个点,r条边
int d1[maxn];
int d2[maxn];
bool used[maxn];
struct edge
{
    int to,cost;
};
vector<edge> e[maxn];
int prev[maxn];
void dijkstra(int s,int *d)
{
    memset(d,INF,maxn*sizeof(int));
    memset(used,0,sizeof(used));
    memset(prev,-1,sizeof(prev));
    d[s]=0;
    while(1)
    {
        int v=-1;

        for(int u=1;u<=n;++u)
        {
            if(!used[u] && (v ==-1 || d[u]<d[v])) v=u;
        }
        if(v == -1) break;

        else
        {
            used[v]=1;
            for(int i=0;i<e[v].size();++i)
            {
                if(d[e[v][i].to] > d[v]+e[v][i].cost)
                {
                    d[e[v][i].to] = d[v]+e[v][i].cost;
                    prev[e[v][i].to]= v;
                }

            }
        }
    }
}

int main()
{
    int i;
    //初始化map
    scanf("%d%d",&n,&r);

    for(i=0;i<r;++i)
    {
        edge temp,temp1;
        int u;
        scanf("%d%d%d",&u,&temp.to,&temp.cost);
        temp1.to=u;
        temp1.cost=temp.cost;
        e[u].push_back(temp);
        e[temp.to].push_back(temp1);
    }


    dijkstra(n,d2);
    dijkstra(1,d1);
    int v=n;
    int semin=INF;
   

    for(;v!=-1;v=prev[v])
    {
        for(i=0;i<e[v].size();++i)
        {
            if( (semin > (d1[v]+e[v][i].cost+d2[e[v][i].to])) && ((d1[v]+e[v][i].cost+d2[e[v][i].to])>d1[n]) )
            semin = d1[v]+e[v][i].cost+d2[e[v][i].to];
        }
    }

    printf("%d",semin);
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值