HDU - 1114 Piggy-Bank (完全背包)

Piggy-Bank


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
 

Sample Input
  
  
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 

Sample Output
  
  
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
 


题意:完全背包裸题,其他条件为求最小价值,和必须填满。


解题思路:《背包九讲2.0》是个好东西,把里面的东西用上直接过,如果是必须填满,求最小时那么初始化为INF,并且用'>',求最大时初始化为-INF,用'<',dp[0]初始化为0,最后只需判断是否等于INF或-INF就能判断是否装满了。详见代码。



#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <vector>
#include <map>
#include <string.h>
#include <algorithm>
#include <queue>
#define INF 1<<29
using namespace std;


int W;
int N;

int v[50005];
int w[50005];
int dp[50005];//前i个物品的最小值

int main(){

    int t;
    scanf("%d",&t);

    while(t--){
        scanf("%d%d",&N,&W);
        W=W-N;
        scanf("%d",&N);

        memset(w,0,sizeof(w));
        memset(v,0,sizeof(v));
        memset(dp,0,sizeof(dp));


        for(int i=1;i<=N;i++)
            scanf("%d%d",&v[i],&w[i]);


        for(int i=0;i<50005;i++)
            dp[i]=INF;

        dp[0]=0;

        for(int i=1;i<=N;i++)
            for(int j=w[i];j<=W;j++)
                if(dp[j]>dp[j-w[i]]+v[i]){
                    dp[j]=dp[j-w[i]]+v[i];
                }

        if(dp[W]<INF)
            printf("The minimum amount of money in the piggy-bank is %d.\n",dp[W]);

        else
            printf("This is impossible.\n");

    }

    return 0;
}











评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值