poj 2299 Ultra-QuickSort(树状数组-改上求下+改下求上||归并排序)

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 60497 Accepted: 22431

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

归并排序,或用树状数组记录,先写树状数组

1:树状数组,对于题目来说 999,999,999的数据范围,开数组肯定要爆内存,由于n只有500000,可以对数据离散化一下,把每个数据改成1~n之间的数,拿第一组数据来说,9最大,9的角标为1,所以让a[1]=5;

先上个改上界,求下界的码,不太好看懂,感觉有点绕;

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define maxn 500010
typedef long long LL;
struct node
{
    int x,pos;
}q[maxn];
int a[maxn],num[maxn];
int n;

int lowbit(int x)
{
    return x&-x;
}

bool cmp(node s,node b)
{
    return s.x<b.x;
}

void add(int i,int x)
{
    while(i<=n)
    {
        a[i]+=x;
        i+=lowbit(i);
    }
}

int getsum(int i)
{
    int sum=0;
    while(i>0)
    {
        sum+=a[i];
        i-=lowbit(i);
    }
    return sum;
}

int main()
{
    while(~scanf("%d",&n),n)
    {
        memset(a,0,sizeof(a));//注意清零
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&q[i].x);
            q[i].pos=i;//记录原始的位置
        }
        sort(q+1,q+n+1,cmp);
        for(int i=1;i<=n;++i)
            num[q[i].pos]=i;//离散化
        LL ans=0;
        for(int i=1;i<=n;++i)
        {
            ans+=(i-1)-getsum(num[i]);//前面有i-1个数,getsum(num[i])为小于num[i]的数
            add(num[i],1);//加入数组中
        }
        printf("%lld\n",ans);
    }
    return 0;
}

下面是自己改的,改下界求上界的码,个人感觉很简洁

既然每次更新的是1~a[i]之间<=a[i]的个数,那么我读取的时候直接读a[i]~n不就是a[i]~n之间>=a[i]的值吗?

关于相等的情况:会有这样一个问题,读取的时候为什么不是a[i]~n之间>=a[i],那么如果出现两个值相等的情况呢?,我考虑了很久关于这个问题,其实没必要,假如出现几个数相等的情况,但经过离散化之后,他们所储存的值是不相等的,原本位置靠后的快排后位置相较于几个相等的值,它依然靠后,这就保证了一个值更新时不会影响后面和这个值相等的值的读取,举个例子:

比如有这样几个数 :1,2,5,5

               离散后  a:1,2,3,4;

更新i=1,2时暂且不谈,

read求和是对a[i]~n;

i=3,ans+read(a[3])  求和3~n           然后更新3,更新3时,更新的是1~3,也就是小于等于a[3]的

i=4,ans+read(a[4])  求和4~n           然后更新4,会发现位置3和位置4都是5,但更新时并没有影响

至于add为什么放后面,因为最后一个数的逆序数一定是0,不需要读取,少读取一次

#include <iostream>
#include <iomanip>
#include<stdio.h>
#include<string.h>
#include<stack>
#include<stdlib.h>
#include<queue>
#include<map>
#include<math.h>
#include<algorithm>
#include<vector>
#define mem(a,b) memset(a,b,sizeof(a))
#define ll long long
#define maxn  500005
using namespace std;
int n;
struct node
{
    int val,pos;
}e[maxn];
int t[maxn],a[maxn];
bool cmp(node a,node b)
{
    return a.val<b.val;
}
int lowbit(int x)
{
    return x&-x;
}
void add(int x,int num)
{
    for(int i=x;i>0;i-=lowbit(i))
    {
        t[i]+=num;
    }
}
int read(int x)
{
    int sum=0;
    for(int i=x;i<=n;i+=lowbit(i))
        sum+=t[i];
    return sum;
}
int main()
{

    while(~scanf("%d",&n),n)
    {
        mem(t,0);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&e[i].val);
            e[i].pos=i;
        }
        sort(e+1,e+1+n,cmp);
       for(int i=1;i<=n;i++)
        a[e[i].pos]=i;
        ll ans=0;
        for(int i=1;i<=n;i++)
       {
           ans+=read(a[i]);
           //每次加上i~n之间小于a[i]的个数
           add(a[i],1);
           //更新1~i之间<=a[i]的个数
     
       }
        printf("%lld\n",ans);
    }
    return 0;
}
再敲一遍归并排序的模板

#include <iostream>
#include <iomanip>
#include<stdio.h>
#include<string.h>
#include<stack>
#include<stdlib.h>
#include<queue>
#include<map>
#include<math.h>
#include<algorithm>
#include<vector>
#define mem(a,b) memset(a,b,sizeof(a))
#define ll long long
#define maxn  500005
using namespace std;
int a[maxn],c[maxn];
ll cnt;
void Merge(int a[],int first,int mid,int last,int c[])
{
    int i=first,j=mid+1;
    int m=mid,n=last;
    int k=0;
    while(i<=m||j<=n)
    {
        if(j>n||(i<=m&&a[i]<=a[j]))
        {
            c[k++]=a[i++];
        }
        else
        {
            c[k++]=a[j++];
            cnt+=(m-i+1);
        }
    }
    for(i=0;i<k;i++)
        a[first+i]=c[i];
}
void merge_sort(int a[],int first,int last,int c[])
{
    if(first<last)
    {
        int mid=(first+last)/2;
        merge_sort(a,first,mid,c);
        merge_sort(a,mid+1,last,c);
        Merge(a,first,mid,last,c);
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n),n)
    {
        mem(c,0);
        cnt=0;
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        merge_sort(a,0,n-1,c);
        printf("%lld\n",cnt);
    }
    return 0;
}






  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值