HDOJ_1008电梯上的时间(Elevator)

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case.
 

Sample Input
  
  
1 2 3 2 3 1 0
 

Sample Output
  
  
17 41
 

Author
ZHENG, Jianqiang
 

Source



问题描述 :

                 我们城市最高的建筑物只有一个电梯。请求列表由n个正数组成。数字表示电梯将按指定的顺序在哪个楼层停止。电梯上一层需要6s,中间停留5s,下一层需要4s。 对于给定的请求列表,您将计算完成列表上的请求所花费的总时间。电梯是在零层开始时,不必返回到地面时,要求满足。 


输入:有多个测试用例。每个案例包含一个正整数n,其次是N正数。输入中的所有数字小于100。n = 0的测试用例表示输入端。此测试用例不被处理。


输出:在每个测试用例的一行打印总时间。


样本输入          
1 2
2 3 1


示例输出
17
41
 

#include<stdio.h>
#include<math.h>
int main()
{
      int i,T,t;
      double m,n,mn;
      while(scanf("%d",&T)&&(T!=0))
      {     
            m=0;t=0;      //m表示电梯的楼层 
            while(T)
            {
                scanf("%lf",&n);
                mn=(fabs(m-n)-1)*5;  //表示电梯运行时候所要花的时间
                while(m!=n)
                {
                     if(n>m)   t+=11 , m++;   //电梯上一层需要5s+6s 
                     if(n<m)   t+=9 , m--;    //电梯下一层需要5s+4s 
                }
                t-=mn;
                T--;
            }
            printf("%d\n",t);
      }
      return 0;
}


杭电OJ1008:http://acm.hdu.edu.cn/showproblem.php?pid=1008

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值