解题报告 之 POJ2769 Reduced ID Numbers

20 篇文章 2 订阅

解题报告 之 POJ2769 Reduced ID Numbers


Description
T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 10  6-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8


题目大意:给定一些不超过1e6的数字,让你找一个最小的数k,使得给出的数中没有任何两个数对k同余。


分析:解题思路是十分朴素的实验法。直接从1开始试每个数字看看有没有同余的,如果找到同余则break,直到找到一个合适的数为止。但是有一个问题是在C++上超时但在G++上却AC了,不知道其中的奥妙何在,求大神提点。


上代码:

#include<iostream>
#include<algorithm>
#include<cmath>
#include<map>
#include<cstring>
using namespace std;

const int MAXN = 1e5+10;
const int MAXM = 1e6 + 10;

int stu[MAXN];
int m[MAXN];

int main()
{
	int kase;
	cin >> kase;
	while(kase--)
	{
		//memset( mod, 0, sizeof mod );
		int n;

		cin >> n;
		for(int i = 1; i <= n; i++)
			cin >> stu[i];
		
		bool flag;
		int i;
		for(i = 1; ; i++)
		{
			memset( m, 0, sizeof m );
			flag = true;
			for(int j = 1; j <= n; j++)
			{
				if(m[stu[j] % i] == 1)
				{
					flag = false;
					break;
				}
				else
					m[stu[j] % i] = 1;
			}
			if(flag)break;
		}
		cout << i << endl;
	}
	return 0;
}

嗯,开始了同余方程。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值