poj 2769 Reduced ID Numbers


Reduced ID Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7346 Accepted: 2971

Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 10 6-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8
#include<iostream>
#include<algorithm>
using namespace std;

int comp(int &a,int &b)
{
return a<b;
}

int main()
{
int nums[300];
int modu[300];
int g;
int n;
int divi;
int i;
cin>>n;
while(n--)
{
cin>>g;
for(i=0;i<g;i++)
cin>>nums[i];
for(divi=g;;divi++)
{
for(i=0;i<g;i++)
{
modu[i]=nums[i]%divi;
}
sort(modu,modu+g,comp);
for(i=0;i<g-1;i++)
{
if(modu[i]==modu[i+1])
break;
}
if(i==g-1)
{
cout<<divi<<endl;
break;
}
}
}
return 0;
}

转载于:https://www.cnblogs.com/w0w0/archive/2011/11/22/2258653.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值