解题报告 之 ZOJ 3329 One Person Game

6 篇文章 0 订阅

解题报告 之 ZOJ 3329 One Person Game



Description

There is a very simple and interesting one-person game. You have 3 dice, namely Die1Die2 and Die3Die1 has K1 faces. Die2 has K2 faces. Die3 has K3 faces. All the dice are fair dice, so the probability of rolling each value, 1 to K1K2K3 is exactly 1 / K1, 1 / K2 and 1 / K3. You have a counter, and the game is played as follow:

  1. Set the counter to 0 at first.
  2. Roll the 3 dice simultaneously. If the up-facing number of Die1 is a, the up-facing number of Die2 is b and the up-facing number of Die3 is c, set the counter to 0. Otherwise, add the counter by the total value of the 3 up-facing numbers.
  3. If the counter's number is still not greater than n, go to step 2. Otherwise the game is ended.

Calculate the expectation of the number of times that you cast dice before the end of the game.

Input

There are multiple test cases. The first line of input is an integer T (0 < T <= 300) indicating the number of test cases. Then T test cases follow. Each test case is a line contains 7 non-negative integers nK1K2K3abc (0 <= n <= 500, 1 < K1K2K3 <= 6, 1 <= a <= K1, 1 <= b <= K2, 1 <= c <= K3).

Output

For each test case, output the answer in a single line. A relative error of 1e-8 will be accepted.

Sample Input

2
0 2 2 2 1 1 1
0 6 6 6 1 1 1

Sample Output

1.142857142857143
1.004651162790698

Source

The 7th Zhejiang Provincial Collegiate Programming Contest

题目大意:有三个骰子,每个骰子分别有K1,K2,K3个面,每个骰子分别印着1~Ki 。每个骰子投中每个面概率相等。有一个计数器,一开始清零,当第一二三个骰子分别投中a,b,c时,则计数器清零,否则就加上三个骰子投出的数字和,一旦计数器大于n就停止。问要使得计数器的数大于n需要的步数的期望是多少?

分析:概率dp的题,用dp[i]表示使计数器达显示n所需要的步数期望。所以很容易得到状态转移方程:


p[j]表示投出j的概率,p[0]表示清零概率

但是很不幸的是,递推公式中包含dp[0],而dp[0]正是我们要求的。不过好在每次递推dp[0]都是线性变化,所以我们可以考虑将dp[0]视为未知数推导到dp[0]=k*dp[0]+b,解方程即可。

于是乎我们令 dp[i]=A[i]*dp[0]+B[i] 。(因为dp[i]中要么是关于dp[0]的一次项,要么是已知常数)。
所以我们可以将上面的状态转移方程表示成另一种形式:

于是乎,我们可以得到A[i]和B[i]的状态转移方程:

在根据之前的定义:dp[0]=A[0]*dp[0] + B[0]   -->  dp[0]=B[0]/(1.0-A[0])

上代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

const int MAXN = 500 + 50;
double A[MAXN], B[MAXN];
double p[50];

int main()
{
	int T;
	cin >> T;
	while(T--)
	{
		int n, k1, k2, k3, a, b, c;
		scanf( "%d%d%d%d%d%d%d", &n, &k1, &k2, &k3, &a, &b, &c );
		memset( A, 0, sizeof A );
		memset( B, 0, sizeof B );
		memset( p, 0, sizeof p );

		double p0 = 1.0 / k1 / k2 / k3;
		for(int i = 1; i <= k1; i++)
			for(int j = 1; j <= k2; j++)
				for(int k = 1; k <= k3; k++)
					if(i != a || j != b || k != c)
						p[i + j + k] += p0;

		for(int i = n; i >= 0; i--)
		{
			for(int j = 1; j <= k1 + k2 + k3; j++)
			{
				A[i] += A[i + j]*p[j];
				B[i] += B[i + j]*p[j];
			}
			A[i] += p0;
			B[i] += 1.0;
		}
		printf( "%.16lf\n", B[0] / (1.0 - A[0]) );
	}

	return 0;
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值