POJ_1014 Dividing解题报告

Dividing
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 43339 Accepted: 10742

Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.

Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1 2 0 0". The maximum total number of marbles will be 20000.
The last line of the input file will be "0 0 0 0 0 0"; do not process this line.

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.".
Output a blank line after each test case.

Sample Input

1 0 1 2 0 0 
1 0 0 0 1 1 
0 0 0 0 0 0 

Sample Output

Collection #1:
Can't be divided.

Collection #2:
Can be divided.

Source

算法类型:DFS
解题思路:先计算所有大理石的价值和,如果和是奇数,就不能平分,如果和是偶数,就进行DFS查找,如果遍历一遍找不到,就说明不能平分。
算法实现;
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<iostream>
using namespace std;
int a[7];   //价值数组;
int V,HV;
int P=1;
int k=1;
bool DFS(int v,int j)   //搜索;
{
  if(v==HV)        //如果找到平分的分配方法,就返回给真;
  return true;
  for(int i=j;i>=1;i--)
  {
	  if(a[i]!=0)    //判断是否还有大理石可以分配;
	  {
		  if(v+i<=HV)
		  {
			  a[i]--;      //因为是平均分为两份,所以如果可以分的话,不在第一种分配情况就在第二种分配情况之中,所以可以直接减掉;
	//	  cout<<k<<"layer"<<endl;   //调试时记录递归层数;
		//	  k++;
			  if(DFS(v+i,i))	//如果找到,各层递归DFS都返回给真;因为没有对v进行直接操作,每次都是调用v+i,所以递归返回时v等于上层的v;值没有发生改变;
			//	 cout<<k<<"end"<<endl;
			 // k--;
			  return true;
			  //a[i]++;
		  }
	  }
  }
  return false;
}
int main()
{
	while(scanf("%d %d %d %d %d %d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6])!=EOF)
	{
		if(a[1]==0&&a[2]==0&&a[3]==0&&a[4]==0&&a[5]==0&&a[6]==0)
			break;
		V=a[1]*1+a[2]*2+a[3]*3+a[4]*4+a[5]*5+a[6]*6;
		if(V%2!=0)
		{
			printf("Collection #%d:\n",P);
			printf("Can't be divided.\n\n");
			P++;
		}
		else
		{
			HV=V/2;
			if(DFS(0,6))
			{
				printf("Collection #%d:\n",P);
				printf("Can be divided.\n\n");
				P++;
			}
			else
			{
				printf("Collection #%d:\n",P);
			    printf("Can't be divided.\n\n");
			    P++;
			}
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值