poj 1260 Pearls 动态规划

10 篇文章 0 订阅
Pearls
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 6796 Accepted: 3324

Description

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class.
Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl.
Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the
prices remain the same.
For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro.
The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one.

Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000).
The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers.

Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.

Sample Input

2
2
100 1
100 2
3
1 10
1 11
100 12

Sample Output

330
1344

Source

Northwestern Europe 2002
链接点击打开链接
这道题的题意很长,不过不是很难,就是输入珠宝的等级越来越高,保证珠宝数量一定(等级低的珠宝可以换取等级高的珠宝并且一次要换完)的情况下每加入一个种类就要把这种种类的数量+10然后求最少的金钱
这道题有很多隐含条件,1、等级差的换取等级好的时候不能越级,因为只有相邻的才会最少金钱
这道题像其他的动态规划一样首先dp[]按类别计算min{dp[i],dp[j]}也按照类别,每次都从小到大计算一次
找到最小的
for(i=1;i<=c;i++)
		{
			dp[i]=dp[i-1]+(num[i]+10)*price[i];
			for(j=i-1;j>=0;j--)//一定要从0开始,不然无法把全部的种类包含进去
				dp[i]=min(dp[j]+(sum[i]-sum[j]+10)*price[i],dp[i]);

		}
sum[i]代表前i个种类有多少珠宝,dp[i]代表前i个种类最少的金钱,这里一定得包含i;从i到j循环找到(i,j]所有的珠宝按照价格i计算找出最小值;这道题让我认识到动态规划的基本思想都是递推,并且要根据题意需要确定是(j,i-1)的递推形式
#include<stdio.h>
#include<iostream>
#include<cstring>
using namespace std;
int dp[1009],num[1009],price[1009],sum[1009];//sum[i]代表前i个种类所需要钻石的数量
int min(int a,int b)
{
	return a<b?a:b;
}
int main()
{
	int i,j,c,n;
	scanf("%d",&n);
	while(n--)
	{
		memset(dp,0,sizeof(dp));
		memset(sum,0,sizeof(sum));
		memset(num,0,sizeof(num));
		memset(price,0,sizeof(price));
		scanf("%d",&c);
		for(i=1;i<=c;i++)
		{
			scanf("%d%d",&num[i],&price[i]);
				sum[i]=sum[i-1]+num[i];
		}
		for(i=1;i<=c;i++)
		{
			dp[i]=dp[i-1]+(num[i]+10)*price[i];
			for(j=i-1;j>=0;j--)//一定要从0开始,不然无法把全部的种类包含进去
				dp[i]=min(dp[j]+(sum[i]-sum[j]+10)*price[i],dp[i]);

		}
		printf("%d\n",dp[c]);

	}
return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值