fosu菜鸟acm新篇章

10 篇文章 0 订阅

Problem C

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 3
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
大数加法,主要意思是求两个数相加,这两个数可以达到32位,int可以达到21亿,__int64可以达到180亿都不能满足,所以必须得把这些数字用数组分开存储
比如a1a2a3--an与b1b2b3--bn相加将每一对应位相加,比如a1+b1判断有没有进位把进位加到a2+b2的和中,相同的a2+b2的进位加到a3+b3中,依次类推
#include<stdio.h>
#include<iostream>
#include<cstring>
using namespace std;
char a[1000],b[1000];
int c[1000];
int main()
{
	int i,j,k,T,lena,lenb,temp,m,len;
	scanf("%d",&T);
	
	
	for(m=1;m<=T;m++)
	{
		memset(c,0,sizeof(c));
		memset(a,'0',sizeof(a));
		memset(b,'0',sizeof(b));
		cin>>a>>b;
		lena=strlen(a);
		lenb=strlen(b);
		printf("Case ");
		printf("%d:\n",m);
		for(i=0;i<lena;i++)
			printf("%c",a[i]);
		printf(" + ");
		for(i=0;i<lenb;i++)
			printf("%c",b[i]);
		printf(" = ");
		for(i=lena-1,j=lenb-1,k=0;i>=0||j>=0;i--,j--,k++)
		{
			if(i>=0&&j>=0)
				temp=a[i]+b[j]-'0'-'0';//这里a[]与b[]都为字符类型变为整形需要减去0的ascII码值,这样才能得整形结果
			else if(i>=0&&j<0)
				temp=a[i]-'0';//判断a[],b[]是否已经加完
			else if(j>=0&&i<0)
				temp=b[j]-'0';
			c[k]=temp+c[k];
			if(c[k]>=10)
			{
				c[k+1]=c[k+1]+1;
				c[k]=c[k]-10;
			}
		}
		if(c[k]>=1)
			len=k;
		else
			len=k-1;
		for(i=len;i>=0;i--)
			printf("%d",c[i]);
		if(m<T)
			printf("\n\n");
		else
			printf("\n");
	}
	
	return 0;
	
}


 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值