POJ 2139 Six Degrees of Cowvin Bacon【floyd】


Six Degrees of Cowvin Bacon

Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 4317

 

Accepted: 2049

Description

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon". 

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case. 

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows. 

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were. 

Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows. 

Sample Input

4 2

3 1 2 3

2 3 4

Sample Output

100

Hint

[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .] 

Source

USACO 2003 March Orange

 

题目大意:有n只牛,m个电影,同时出演一个电影的牛之间距离为1,问哪只牛距离其他牛的距离和最小,并输出(ans*100)/(n-1)即可


思路:人际关系递推可以用floyd求传递闭包,所以问题可以转化到最短路上来做,因为点比较少,n^3不会超时,所以我们采用floyd算法即可轻松AC。


AC代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int map[500][500];
int a[5000];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                map[i][j]=0x3f3f3f3f;
            }
        }
        for(int i=0;i<m;i++)
        {
            int k;
            scanf("%d",&k);
            for(int j=0;j<k;j++)
            {
                scanf("%d",&a[j]);
                a[j]=a[j]-1;
                for(int z=0;z<j;z++)
                {
                    map[a[z]][a[j]]=1;
                    map[a[j]][a[z]]=1;
                }
            }
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                for(int k=0;k<n;k++)
                {
                    map[j][k]=min(map[j][k],map[j][i]+map[i][k]);
                }
            }
        }
        int ans=0x3f3f3f3f;
        for(int i=0;i<n;i++)
        {
            int sum=0;
            for(int j=0;j<n;j++)
            {
                if(i==j)continue;
                sum+=map[i][j];
            }
            ans=min(sum,ans);
        }
        //printf("%d\n",ans);
        printf("%d\n",ans*100/(n-1));
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值