Poj 2823 Sliding Window【单调队列学习】模板记录

Sliding Window
Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 62889 Accepted: 17951
Case Time Limit: 5000MS

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source


题目大意:


求每个窗口的最大最小值。


思路:


区间RMQ问题,这里温习(重新学习)一下单调队列。

单调队列基础操作:

①出队,我们首先将老元素从队头依次出队。

②入队,我们从后向前扫,找到第一个小于(大于)当前入队的元素之后,将当前元素放到这个位子后边,同时删除所有后边不必要存在元素。


那么对应这个题,我们出队之后入队然后查询即可。


Ac代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
struct node
{
    int val,pos;
} q[3500000];
int a[3500000];
int ans[3500000];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1; i<=n; i++)scanf("%d",&a[i]);
        int s=0,e=-1;
        for(int i=1; i<=n; i++)
        {
            while(s<=e&&q[s].pos<i-m+1)s++;
            while(s<=e&&q[e].val>a[i])e--;
            e++,q[e].pos=i,q[e].val=a[i];
            if(i>=m)ans[i]=q[s].val;
        }
        for(int i=m; i<=n; i++)
        {
            if(i>m)printf(" ");
            printf("%d",ans[i]);
        }
        printf("\n");
        s=0,e=-1;
        for(int i=1; i<=n; i++)
        {
            while(s<=e&&q[s].pos<i-m+1)s++;
            while(s<=e&&q[e].val<a[i])e--;
            e++,q[e].pos=i,q[e].val=a[i];
            if(i>=m)ans[i]=q[s].val;
        }
        for(int i=m; i<=n; i++)
        {
            if(i>m)printf(" ");
            printf("%d",ans[i]);
        }
        printf("\n");
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值