POJ 2533 最长上升子序列 [动态规划 + 二分搜索]

10 篇文章 0 订阅
2 篇文章 0 订阅

题干

Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input

7
1 7 3 5 9 4 8
Sample Output

4

题解

#include<cstdio>
const int INF = 1e9;
const int MAX = 100010;
typedef int T;//root[]数组的数据类型
//二分搜索
int binary_search(T s[], const int digit, const int len){
  int l = 1, r = len, mid;
  //s[]数组大小为 len - 1 ,且一定是上升序列(可反证法证明)
  while(l<r){
     mid = (l + r) / 2;
     if(s[mid] == digit){
        return mid;//如果s[k]==digit,则返回k
     }else if(s[mid] > digit){
        r = mid;
     }else{
        l = mid + 1;
     }
  }
  //返回 max{ k } + 1(k满足 s[k] < digit)
  return l;
}
inline int LIS(T root[], int length){
  int len = 1, j;
  T s[MAX];//表示当dp[k]==i时,s[i]值为min{root[k]}
  for(int i=1;i<=length;i++){
     s[len] = INF;//len一定指向s数组最后一个有效元素的下一个位置
     j = binary_search(s,root[i], len);
     if(j==len){//当j==len, root[i]为最长子序列中元素,len++
       len ++;
     }
     s[j] = root[i];//保证当dp[k]==i时,s[i]值为min{root[k]}
  }
  return len-1;
}
int main(){
  //freopen("in.txt","r",stdin);
  //freopen("out.txt","w",stdout);
  int N;
  T root[MAX];//原数组(字符串或者数列),root[0]不保存数据
  while(~scanf("%d",&N)){
     for(int i=1;i<=N;i++){
        scanf("%d",&root[i]);
     }
     printf("%d\n",LIS(root,N));
  }
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值